Firmware for APM 2.0

Hello, i am using APM 2.0 for my quadcopter. i have downloaded the mission planner from APM site but now as the manual says, when i have to choose the motors layout, (i have plus configuration) but the mission planner isn't showing any option for plus configuration, though it don't matter much because cross configuration is nearly the same. the confusion that i'm having is that on the mission planner in the initial setup below the cross configuration is written 'Arducopter V3.1.3' which means that when i'll click that it will load V3.1 firmware in the board whereas APM 2.0 cant support firmware above 2.1 i suppose, any help?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • thankyou for replying. :)

  • Moderator

    APM 2.0 can load and run v3.1.3 no problem, as can APM1.4, 2.5 & 2.6.

    Future versions of APM:Copter (vis. v3.2) may not be able to load the code or will have new features missing due to running out of space on the board.

    Plus and cross have a fairly major difference, plus flies with one motor forward while cross flies with two motors forward.

This reply was deleted.

Activity

Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…