Help with 3DR radios in MP

I have several pairs of 3dr and clone 433MHz radios which were all working fine three days ago. They are all recognised using the standalone 3dr SiK radio software and when connected through that software the RSSI is ~180+ . The issue comes when I try to connect in MP when everything just times out. I have tried everything I know, including reinstalling MP and yet there is still no connection. I have tried this with both a 3DR Pixhawk and a drotek dropix (different cables and connectors)controllers but the same problem persists.

Any suggestions for what to try next would be greatly appreciated.

Many thanks in anticipation of your help.

Darrel

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Selling an extra Emlid Reach RTK Kit if anyone is interested.  Only used for bench testing and setup...never flown! http://www.rcgroups.com/forums/showthread.php?t=2750520


  • Here are a few things to try: Can you try to connect to Tower app?  In MP does a com port show up in the list when you try to connect? Does the com port change when you try a different USB port on your computer? It should, if not, troubleshoot there. Goto device manager, find and delete the radio, then let windows find the driver again. You can check for updates on the help tab. I always get the BETA updates which are usually very stable. How are you connected to pixhawk(which port)? Telem1? Whats in telem2? Switch them if possible. Hope this helps.

  • Hi Chris

    The radios are fine on the SiK tab - they connect and both sets of radio parameters show up correctly. When I then try to hit connect in MP (to download parameters etc)  it just times out. 

    It seems like a software issue to me but I cannot comprehend what is happening.

  • Just to be clear, it is the radio that wont connect or the vehicle? Does MP recognize the radio, on the SiK radio tab? Or are you just having trouble connecting the vehicle with MP? Also, I have had no issues after Win10.

  • Yes I did wonder about the sequence of power-up but I have now tried this on two airframes (a hex with the dropix and a fixed wing with a 3dr pixhawk), the hex has only a drotek SMARNAV RTK system and the fixed wing an emlid REACH RTK system. Neither have a gimbal and both had worked fine earlier in the week! I will try again later but happy to be going on holiday tomorrow when I will try to forget about this for a while :) 

    Thanks for the suggestion. I  think this has to be a software issue - does anyone know if the latest Windows 10 update (the only change to the machine since earlier in the week) could have corrupted anything? Just clutching at straws now.

     

  • Darrel:

    I have had a similar problem.  In my case I have a storm 32 gimbel controller connected to the pixhawk via mavlink.  In this setup MP connects to mavlink, then downloads parameters for each device separately.

    If I attempt to connect mission planner prior to the gimble completing its start up routine, then mission planner will not connect at all, with the behavior you describe.  If this happens once then I need to remove all power, reconnect, wait to allow gimble to start up, only then will MP connect.  Perhaps, as in my case, the start up of each device, is affecting the communication, not the radio.

  • Thanks James,

    They are set correctly  - indeed the Sik radio connection does not work if these are incorrect. That continues to work showing a strong connection and the standalone 3dr radio checker shows little interference(noise), but still I cannot get mavlink connection for telemetry.

    I am baffled :( 

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @knightsautoteam: Hi @diyrobocars, we are Orlando's first Autonomous racing club and would love your support. We are hosting our first K…
Friday
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
Jan 16
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
Jan 16
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
Jan 16
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
More…