Help with 3DR radios in MP

I have several pairs of 3dr and clone 433MHz radios which were all working fine three days ago. They are all recognised using the standalone 3dr SiK radio software and when connected through that software the RSSI is ~180+ . The issue comes when I try to connect in MP when everything just times out. I have tried everything I know, including reinstalling MP and yet there is still no connection. I have tried this with both a 3DR Pixhawk and a drotek dropix (different cables and connectors)controllers but the same problem persists.

Any suggestions for what to try next would be greatly appreciated.

Many thanks in anticipation of your help.

Darrel

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Selling an extra Emlid Reach RTK Kit if anyone is interested.  Only used for bench testing and setup...never flown! http://www.rcgroups.com/forums/showthread.php?t=2750520


  • Here are a few things to try: Can you try to connect to Tower app?  In MP does a com port show up in the list when you try to connect? Does the com port change when you try a different USB port on your computer? It should, if not, troubleshoot there. Goto device manager, find and delete the radio, then let windows find the driver again. You can check for updates on the help tab. I always get the BETA updates which are usually very stable. How are you connected to pixhawk(which port)? Telem1? Whats in telem2? Switch them if possible. Hope this helps.

  • Hi Chris

    The radios are fine on the SiK tab - they connect and both sets of radio parameters show up correctly. When I then try to hit connect in MP (to download parameters etc)  it just times out. 

    It seems like a software issue to me but I cannot comprehend what is happening.

  • Just to be clear, it is the radio that wont connect or the vehicle? Does MP recognize the radio, on the SiK radio tab? Or are you just having trouble connecting the vehicle with MP? Also, I have had no issues after Win10.

  • Yes I did wonder about the sequence of power-up but I have now tried this on two airframes (a hex with the dropix and a fixed wing with a 3dr pixhawk), the hex has only a drotek SMARNAV RTK system and the fixed wing an emlid REACH RTK system. Neither have a gimbal and both had worked fine earlier in the week! I will try again later but happy to be going on holiday tomorrow when I will try to forget about this for a while :) 

    Thanks for the suggestion. I  think this has to be a software issue - does anyone know if the latest Windows 10 update (the only change to the machine since earlier in the week) could have corrupted anything? Just clutching at straws now.

     

  • Darrel:

    I have had a similar problem.  In my case I have a storm 32 gimbel controller connected to the pixhawk via mavlink.  In this setup MP connects to mavlink, then downloads parameters for each device separately.

    If I attempt to connect mission planner prior to the gimble completing its start up routine, then mission planner will not connect at all, with the behavior you describe.  If this happens once then I need to remove all power, reconnect, wait to allow gimble to start up, only then will MP connect.  Perhaps, as in my case, the start up of each device, is affecting the communication, not the radio.

  • Thanks James,

    They are set correctly  - indeed the Sik radio connection does not work if these are incorrect. That continues to work showing a strong connection and the standalone 3dr radio checker shows little interference(noise), but still I cannot get mavlink connection for telemetry.

    I am baffled :( 

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…