Hexacopter crash. Please help!'

Guys, today i took my F550 out with a brand new 4S 3300mah battery. One motor was not behaving correctly and started twitching back and forward as the other motors were all spinning as expected. The hex took off and hit the ground hard, breaking one of the arms.Just before this, i flew with a 4000mah 3S with no issues at all.Any ideas what this could have been? This only happens with the 4S battery. ESCs are Turnigy plush 30A and apparantly rated to anything from 3S To 6S.Motors are NTM porp drive 2830 750KvAny ideas much appreciated!Thanks!!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • So today, another flight gone bad, REALLY bad. Crashed breaking 2 arms and a very confused mind!

    Replaced the motors with these

    http://www.google.co.nz/url?sa=t&rct=j&q=&esrc=s&so...

    And again, the 3S was a smooth flight, however quite short. But the 4S, very very erratic and 20 secs into flight just starting behaving so badly it just FLEW into the ground, with force. I noticed an alarm on my transmitter come on. and also the low batt alarm on the hex would beep when i gave it throttle, when i loosened off the beep would disappear, both these batteries were fully charged!

    Heres my setup

    http://www.google.co.nz/url?sa=t&rct=j&q=&esrc=s&so...

    http://www.hobbyking.com/hobbycity/store/uh_viewItem.asp?idProduct=...

    on this frame

    http://www.hobbyking.com/hobbyking/store/__24175__H550_V2_Glass_Fib...

    Flying a APM 2.5, DX8 with TM1000 telemetry. Are these motors too big for this frame!

    Im starting to loose faith :(

    Please help!

    http://www.google.co.nz/url?sa=t&rct=j&q=&esrc=s&source=web&cd=2&ved=0CDIQFjAB&url=http%3A%2F%2Fclu…
  • May be, the reason is that the propeller was not fixed properly.

  • Ok, so heres ive made videos, got pictures of what ive done etc.

    Heres the deal

    This is what happens

    https://www.youtube.com/watch?v=1R4izyoZO_U

    Sorry, i know its not the right way up

    https://www.youtube.com/watch?v=LgaJrlozGNo

    Ive redone the power distribution board as i didnt trust it, left it out altogether. I replaced it with with a harness

    3692745446?profile=original

    3692745387?profile=original

    3692745526?profile=original

    Same problem, motor twitching ONLY on the 4S, nearly crashed again

    Any ideas, really getting annoyed with this one

    Cheers

  • Sounds like an ESC or possibly a motor issue. Just 4S/3S switching shouldn't do anything like this. No offense to Hobby King or to you for going the inexpensive route, but these are cheap components. Maybe there's an insulation failure happening at the higher voltage, or some other such, or an ESC programming issue. I would switch the twitching motor with another one and see what happens (with the hex tied firmly to the bench, or with props off (make a mark on the motor bodies so you can see what's happening)). As for the APM, there should be no fundamental difference between 3S and 4S other than the throttle stick sensitivity and matters related to that (alt hold stick behavior etc.). That 30 second business doesn't sound right either. Another thing you can try is running that ESC/motor directly via the receiver, first disconnecting the APM from the receiver altogether and also unplugging one lead from all the other motors (to avoid any nasty surprises). So set up simply like a plain vanilla R/C plane.

  • Andrew makes an interesting posit.

    Obviously the throttle response will be significantly different. That is to be expected.

    A deeper question is if the code applies specific ESC drive dependent on battery value, B+.

    The B+ does not affect APM board voltages, they are regulated external with the PM/BEC/etc.

    Interesting idea.

    -=Doug

  • Correct me if im wrong, but if your APM is tuned running off a 3S Lipo for all the PIDS and then you plug in a 4s, its going to be much higher powered and will require FULL tuning before flight.

    I certainly know that the 1 time i tried switching from a 3s on a perfectly balanced and PID tuned quad to a 4s the thing flew like it was about to shake itself to bits! 

    Just something to bear in mind, (unless like i said im wrong!)

    Motor not running, could the ESC configuration also affect operation with the switch to 4s...

  • So  just took the hex out again today, and as usual the 3S was a very stable flight all went well. Changed over to the 4S and the prop was turning this time so i took off, take off was extremely shaky, almost like heavy oscillation.

    Once flying with 4S, i had alot (alot more then the 3S) of oscillation.

    Why would this be? Is this the battery thats causing this. I must say, im really confused as to how if flies well with the 3S and not at all reliable with the 4S.

    Thanks!

  • HERE is another 'side exit' wiring situation.

    It just depends on the radius (to center) of the motor mount holes.

    -=Doug

  • Thanks for the reply guys, this is a hobbyking knockoff frame, which also has the "power distribution board" as the bottom plate. I thought about it for, literally days before making a decision to use the default power distribution board or using wires and a large blob of solder. The default power distribution board was a much neater option so i went with this, not sure if this could be related.

    around as far as ESC startup tunes etc, It was to my bad judgment to take off when i knew things were wrong, thinking maybe the motor just needed more throttle to engage properly as this is not the first time its happened (2nd since built, with same 4S battery only). I purchased a spare ESC and motor when buying these parts, so when replacing the arm, i replaced the motor and ESC at the same time!

    Darren, I am sure my solder connections are good, im quite pedantic about this when building. The 3S flight was great, also quite a good flight time. Ive only had this issue with this 4S battery! So far anyway!

    Thanks for the replys guys, im hoping to get out tomorrow and do more testing. I must say I just powered up in my room (with props on :S) and behavior appeared to be normal, so maybe it was a faulty ESC or motor, or it is heat related!

    Attached is photos of the build, i had to mount the motors to the side as they didnt fit, i think i ordered the wrong size for the frame making wiring a little bit of a nightmare and not ideal!

    Cheers!

    IMG_0341.JPG

    IMG_0342.JPG

  • I agree with Doug on wiring... did the flight on 3s go ok? how about the landing?

    A twitching motor is usually an indication of one of the three motor side wires from the esc being disconnected(loose). You can reproduce the effect by disconnecting one of the 3 bullet connections to a motor; (do this only if you would like to confirm if that was the symptom you witnessed.)

    Otherwise a power side connection to the pdb or an esc would not cause the same reaction to the one motor.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Jetsonhacks: And I helped with the course! JetBot, JetBot, happy little JetBot! JetBot ... GO! Meet the Jetson Specialists Inspiring a…
8 hours ago
DIY Robocars via Twitter
RT @a1k0n: Designed RPi + camera mounts + new bumper for the new car. Fits great on the car first try, except my longest camera cable doesn…
8 hours ago
gotham liked gotham's profile
yesterday
DIY Robocars via Twitter
RT @RoboticMasters: Monaco GP Circuit in the Donkey Sim (coming soon). Including buildings, tunnel and all! https://github.com/robotics-masters/sim-donkeycar-f1/tree/f1-tracks @diyr…
Wednesday
DIY Robocars via Twitter
RT @breadcentric: Here are the details of #AWSDeepRacer finals: https://blog.deepracing.io/2020/12/01/aws-deepracer-league-finals-2020-round-1-schedule/ #awsreinvent2020 #AWSreInvent https://t.co/ovqsjp8V…
Wednesday
DIY Robocars via Twitter
RT @breadcentric: #AWSDeepRacer League #awsreinvent2020 Open race is on Dec 1st - Dec 31st in three categories, 15 DeepRacer Evo (with LIDA…
Wednesday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars It's just something that's easy to track with chroma keying. I ended up using different colors on th…
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Nov 23
DIY Robocars via Twitter
Nov 23
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
More…