I need help in crash investigation

Hello,

I had a crash with my Tarot Ironman 650 with an APM 2.5.2 control board and APM:Copter firmware version 3.1.5. I flew about 9 minutes switching between "stabilize" and "loiter" mode. Everything worked well and the copter flew as stable as always although the copter was not correctly balanced without the camera gimbal.

The copter was in "Loiter" mode when suddenly he made a role and crashed into the ground. I checked the motors and ESCs and all connections. Everything was fine. 

When I searched the telemetry and flash logs, I couldn't find the reason for the crash.

It would be great when some experts could have a look on my log files.

Thank you in advance.

Sandro

You need to be a member of diydrones to add comments!

Join diydrones

Replies are closed for this discussion.

Replies

  • I'm going to say it was a mechanical or electrical failure on your rear right motor. Your roll and pitch outs were tracking your inputs just fine until around line 18416, when your pitch and roll started going very positive (that means pitch up and a roll to the right). This is consistent with a loss of power to the right rear motor. Also at that same time your throttle out started to increase rapidly and your NTUN desired pitch and roll values were opposite what the quad was doing. In other words, the APM was increasing the throttle and trying to stop the roll/pitch motion from happening. This roll wasn't something either the APM or you asked the quad to do. It just did it.

    So it sounds like a power failure to the right rear motor. The two most likely possibilities would be a failing ESC (maybe from heating) or a bad electrical connection (like a solder joint). A less likely possibility would be a bad motor.

    • Thanks for your help.

      I'm using MultiStar 4108 380kv 22pole with Afro Slim 20Amp ESC (SimonK). I read about some sync issues on SimonK firmware with 22 pole motors. However I checked how the motors perform with these ESCs before I first flew the copter. I had several flights before (with Loiter) and I never had any issues.

      Would it be possible that those sync issues occur occasionally? Do you think some fast control changes while "Loiter" mode could produce a sync issue?

      • I tested my rear right motor intensively for about 15 minutes. The ESC got hand warm and at the end, the motor responded as good as normal to my commands. 

        I tested it against some sync issues too. If the difference in value is about half throttle between the commands, the red LED flashed very shortly and the motor works as normal.

        So I think, it isn't a sync issue nor an overheated ESC. What else could I test to get the real cause of the crash?

        • Sync issues are probably rarer than most people think. And in Loiter there usually isn't the type of rapid throttle changes that cause that sort of thing. In any case if you tested your quad for 15 minutes by rapidly moving the throttle, with no problems, you likely don't have a sync problem.

          At this point I'd look at connector issues, like barrel connectors to the right rear motor as well as the servo lead to it from the APM. For example it could be a poor crimp in the signal lead in the servo connector that would only show up very occasionally.

          • And one other thing....A pitch up and roll right is consistent with the failure of the right rear motor. But another thing that could cause that movement would be for the front left motor to be stuck on full power. But I think a full on failure is less likely than a full off failure. Something to consider.

            • Thank you for your help. I'll resolder all bullet connectors on the ESCs (motors are soldered directly to the ESC) and probably try to solder the crimped signal wire as well to be sure to have a reliable connection.

    • I want to stress that I'm extremely new to log analysis, so please forgive me if this doesn't add to the discussion.

      Tom, is it significant that current ("Curr") drops immediately before the pitch issues begin?3702512840?profile=original

      • Current plotting against attitude can sometimes be misleading due to the different update rates for the parameters. The data points for current are much more spread apart than for attitude. In your plot, at 18.4 the current and roll appear normal. The next time current is recorded isn't until about 18.43, at which time the roll event had been well underway. So there's really no data that says what the current was doing right at the time the roll began.

        • Thank you very much for the clarification. I really should start looking at the raw data points sometimes.

  • Looks like GPS/MAG issues to me. Try setting your copter on the ground and see if it wonders around in MP map. It acts like it doesn't know which direction it's heading.

    7KxR982.png

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…