Hi,

I bought an IRIS+  in 2015 with a Tarus camera gimbal and flew it a few times-- including some auto Missions.  Then I discovered 3DR had gone out of business and the copter has largely sat on the shelf for 7 years.  I just bought 3 new batteries for the copter and one for the radio  and the copter flew fine for 5-6 times--including 1-2Missions loaded on from Mission Planner.  

--Then I began getting the blinking yellow light instead of the blue green light sequence indicating successful pre-arming checks and GPS lock.  Also, every time I hooked the copter to Mission Planner (Ardupilot), I got a message about updating the firmware on the Pixhawk-- so I followed the instructions on the arducopter website and installed new firmware.  The instructions said the parameters would remain unchanged, but after the upgrade, it has been nothing but trouble-- one arming message after another: "needs accelerometer calibaration", "Arming light problems" etc.  Also, the safety button/arming light acts very bizarre, and other things.  For example: LED on copter after plugging in battery turns blue (after red/blue flashing pre-arm checks), I get a solid blue light and a message about the arming button,-- I push the arming button and it goes from flashing red to solid, and the other led goes from blue to flashing green, then solid green (supposed to mean GPS FIX), but down/right on the radio does not start the props.  Also, camera gimbal no longer responsive to radio controller.  

--Sorry about the long rant-- but it's a mess.

I tried loading the stock prams back on the copter from the drop-down menu in Mission Planner, but that didn't help.

---Bottom line: I am grounded and don't know how to proceed:  --how can I just get this copter back to the original configuration-- which worked?

--Obviously I'm no expert at this, but I can follow instructions.

Thanks in advance,

Bob

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Bob - well, I had a very similar issue with my +. It sat for several years due to 'life', and when I went to fly
    again the accel just wouldn't calibrate, etc. I pulled the PX4, and installed a 2nd one I had on a DIY '450.
    For the new PX4, I installed the latest 'Copter, which was Ver. 4.1.5. After all that, the Iris flew well on default
    parameters, which you have to tune. You'll need to set up the battery voltage failsafe, etc.
    The original 3DR GPS is Neo-6xx U-BLOX, GPS only. I retrofitted a Neo-M8N GNSS receiver, which allows much faster
    GPS lock. (Presently working on a RTK GPS setup for the IRIS.)
    I have since upgraded to 'Copter 4.2 with no issues. Make sure to use the latest Mission Planner...flying great!
    ---
    If it helps, I could send you my full parameter tree which should fly for your IRIS+. The only things I really changed were the
    GPS parameters, as I set it up externally with U-Center.
    Feel free to ask anything - your + will fly again.
    John
    • John,
      Thank you very much for the reply.
      During the past two days I've spent a lot of hours with Mission Planner and the IRIS+, and I am slowly getting more comfortable with it (both the copter and the extensive abilities of MP. I am really a novice at this stuff and I don't have an engineering or computer background, so I have been timid about making PRAM or "Setup" or "Configuration" changes.
      I finally got the copter in the air yesterday evening-- so that's a start!
      Do you have a Tarot gimbal and "FPV" ) to transmit the aerial camera image to a Black Pearl screen on the ground? __ would loading your pram file include the PRAM settings for the gimbal and the FPV? I'm exposing my ignorance about this-- but that's how it goes--can't learn if you don't ask!
      If your IRIS+ PRAM file does not include the gimbal prams and the FPV prams-- do you know if there is a depository of IRIS+ PRAM files out there somewhere to get my copter back to it's original settings? Not sure, but I think if there was someone out there with an IRIS+ with the Tarus gimbal for Gopro, and the FPV function--couldn't they just download their PRAM file and send it to me?
      Thanks again for responding,
      Bob
      • Hi Bob - well, now we're out of my comfort zone - I know nothing about gimbals, etc. I primarily fly an el-cheapo
        entry level GoPro or other 'scientific' payloads. But somewhere, possibly on the 3DR Pilot forum, I've seen chatter
        about Tarus.
        So how did it fly? Did the battery failsafe trigger correctly? I had to setup (and recalibrate) the voltage/current
        sensor, etc.
        Let me know if you do want the complete parameter tree - but if you're passing the prearm checks and flying
        you're 90% home free! John
        • Good morning John,
          I got the copter flying on auto yesterday--flew a couple of "Missions" and all went well: the gimbal works as it should--except that I can't control the "tilt" (aiming the camera up or down) using a knob on the RC radio. There is a Legacy information section in MP online for setting up the Tarot gimbal--but I haven't gotten the "tilt" to work yet.
          I have kept the copter near me because I'm not sure about the battery failsafe setup or the other Failsafe setups-- I found that stuff in MP (setup and config) but I want to get the failsafes working and tested (if possible) for low battery and loss of RC contact.
          Yes, I would like to see the complete parameter tree file you loaded on your Pixhawk--that would be great. I believe I can compare the prams currently on my IRIS+ with the ones you send me- thanks in advance.
          ---small world-- I see you are in Pittsford VT-- I grew up in Hanover, NH.
          Best,
          Bob
          • Outstanding Bob! It sounds like you went from zero to 95%! Did you do a total firmware rebuild and
            all the calibration steps - I think you originally had arming issues. Definitely do the failsafe setup if you're flying missions -- is your telemetry working? I had issues with telemetry (altitude and speed) as
            I was experiencing GPS glitches on the original unit as it only uses GPS birds and not the other constellations. This caused the altitude telemetry to suddenly report MSL instead of AGL and other
            glitches. I don't have the best satellite view here and have to travel to friends to really fly (they have farms and a view!)
            Yesterday I grabbed the full param tree and full list. I'll pass them this a.m. once I get some coffee in my body. I've been in VT for ~25 yrs, having moved from Milford, NH - small world as you say!
            As far as the tilt control, is it possible the RC channel just isn't linked to the gimbal? There is all that setup available in MP to select what channel does what - like CH 7 is the 'land' enable' switch, etc.
            A few months ago I replied to your query regarding IRIS parts; I think it was on 3DR Pilots...if you need parts there is a guy that has almost everything. OK Bob, I'm going to get functional here and I'll get the files to you before noon! Safe Flying, my friend! John
            • Bob, quick question: Did the tilt originally work before you retired the bird for awhile? John
              • Hi Bob - it looks like you need to configure Channel 6 for gimbal control.
                OK, I'm sending the params. Change 'GPS_GNSS_MODE' to 0. (Use As Configured) My param supports the GNSS receiver I retrofitted... John
                • Bob, do you know how to post a file here? I don't see any way to send, and there is no
                  "Private Message" capability.
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
More…