Hi!

I've been running MAVproxy on a Lubuntu 14.04 OS as a forwarding tool to communicate with my Pixhawk/PX4 through the mobile network. The Pixhawk sends data to MAVproxy which forwards to the IP of the ground control station. However, the connection between the MAVproxy and the Pixhawk is lost randomly after being active for a while. This mostly happens at launch of the UAV, leaving me connectionless throughout the flight. I've been doing some troubleshooting and found that it's only MAVproxy that loses the connection with the autopilot. MAVproxy gives the message  "Link 1 down" and then proceeds by sending "no link" indefinitely, until the system is restarted. The computer (Odroid XU3) is still connected to the autopilot during this time and is continuously receiving data. After restart it finds the connection again and the communication is healthy for a while and then the issue comes back. Have anyone encountered this issue before or has an idea of how it can be resolved? What other options is there than MAVproxy if you want to forward mavlink commands to the internet?

Any information is appreciated!

Views: 870

Reply to This

Replies to This Discussion

Are you using tcp or udp as the connection protocol to the gcs...? If your using tcp then a dropped connection will happen each time your ip address changes, which happens when you are on a different mobile phone tower, try using udp instead. Otherwise it seems you could tweak the install to restart mavproxy when it looses the link, or tweak mavproxy itself to do the same,

I'm using UDP and run the connection through a VPN tunnel so that the IP never changes. Although, that shouldn't matter since the mavproxy is directly connected to the autopilot via the telemetry port.  Restarting mavproxy automatically could perhaps make it possible to regain the link, but I would rather never loose it at all. If I can't resolve this data link issue I might try to find another way to forward the connection.

Hi Anton Lidbom, I am stuck at same stage. I get link 1 down and then keep getting "no link". Did you manage to find a solution?

Thanks for sharing.

I get the same message. did you found the solution?



Akshay Mahadev TIMMALAPUR said:

Hi Anton Lidbom, I am stuck at same stage. I get link 1 down and then keep getting "no link". Did you manage to find a solution?

Thanks for sharing.

I think so,

add these lines to config.txt 

enable_uart=1
dtoverlay=pi3-disable-bt

and make sure your baud rate is 57600 and use /dev/ttyAMA0 and not /dev/ttyS0.

I did this and it worked! good luck

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service