My configuration:

Windows vista 32 bits, dell laptop computer, usb cable, arducopter 2.6 mega

1. I downloaded the latest version of the mission plannner ver:3.17 and installed it. Load the mission planner. I have com 5 detected by the MP.

2. Connect my apm 2.6 to my laptop. First a red and blue lights where blinking and afterwards the red light was blinking two blinking and start again.

3. I got a message from the operating system new usb was device was detected and after a while i got a message device will not work properly error 10.

4. I looked at the device manager and i saw:  

  - under the usb devices list: unknown usb device

  - And fddi converter device  with yellow rectangle that mean that the device is not working properly

5. I entered into the MP -> intial setup -> install firmware and try to load into my apm the firmware.

6. I chose my frame. The process start and then i got the following error:

Failed to download new firmware: System argumentException. The given port name does not start with com/COM or doesn't resolve to a valid serial port.

What can be the problem?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hey, I tried to install it but I had an error saying windows was unable to install your unknown device.

    Any ideas about what happened!! Thanks

    Ronen Aknin said:

    Hi

    After a little research i succeeded to solve my problem, i hope you will solve yours.

    To solve this problem:

    0. Turn off the mission planner.

    1. go to http://www.ftdichip.com/Drivers/D2XX.htm

    2. Download the drivers according to your OS, in your case windows 8.

    3. Install the drivers.

    4. Open the mission planner.

    5. You will see another port name beside the port you saw in the begining, choose that port.

    Now you are ready to go.

  • Looks like the Pixhawk driver was not detected and loaded.  Right click on failed device and update driver.  It should have been loaded when Mission Planner was installed.

    • Hi,

      same problem here under win 8.1 with full access, have tried several time to un-install the application and the 4 drivers install from the msi but no way, whenever I connect the usb cable, the lights of the module blink and all is ok with the quadcopter the it's not recognize at the side of the computer ! Is there any way to have an exe for the installation of the drivers alone (not a msi file - important) to allow to run it in administrator mode ?

      Thanks in advance,

      Sincerly,

      Domi.

      • Hi

        After a little research i succeeded to solve my problem, i hope you will solve yours.

        To solve this problem:

        0. Turn off the mission planner.

        1. go to http://www.ftdichip.com/Drivers/D2XX.htm

        2. Download the drivers according to your OS, in your case windows 8.

        3. Install the drivers.

        4. Open the mission planner.

        5. You will see another port name beside the port you saw in the begining, choose that port.

        Now you are ready to go.

        • This seems interresting !

          Thanks a lot,

          Domi.

          • Update me and tell me if it solved your problem. 

  • Looks like the Pixhawk driver was not detected and loaded.  Right click on failed device and update driver.  It should have been loaded when Mission Planner was installed.

    •  I installed the mission planner on windows 7 the drivers were installed correctly and the apm wasd detected correctly. I will now install the vista drivers from http://www.ftdichip.com/Drivers/D2XX.htm and see how it be. The issue is that in the installation of the mission planner the mission planner has to detect first the windows OS and then acoording to this should install the appropriate drivers.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
More…