Mission Planner connection issues

I have just joined DIY Drones and my son and I are doing things the hard way as we are trying to work things out as we go along.

We have mission planner and the APM 2.5 board

When we try and connect we get error messages saying "Cant open serial port"

We are on Windows 7 and have tried the same exercise on 2 PCs now with Windows 7

We have followed all the instructions but we are at a roadblock that seems to be doing its job very well.

I have searched the forum but I cant find anything that has helped us solve the issue.

We have reloaded drivers, ports, MP and so on.

If anyone has some advice we would love to hear from you.

We use our quad for general GoPro stuff on our outdoor activities but we were keen to get a little GPS control.

Our Youtube name is JBBunno if anyone is interested to have a look.

Thanks in advance

JB

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Same problem.  Tried all the same and much more.. Any answers?

  • Hello John
    I'm a complete newbie just getting into the fpv hobby. I purchased the arduflyer 2.5 board and apon first boot, before soldering any pins I ran into the exact same issue you had. I totally understand your frustration for I have tried everything to get this thing to connect to the mission planner. I have read this forum completely desperately hoping for the fix but it would appear there is none. So before I breakdown and try to contact RC Timer I was wondering if you have learned anything more on the issue and possibly have any more ideas.
    Thanks,

    Matt

  • Hello,

    I am a newbie having the same issue that John describes.  I've got my first quadcopter assembled, I installed/uninstalled/reinstalled MP multiple times.  Downloaded and installed updates to directX and .Net framework,  through this process.  I've also installed both the Ardunio Mega and the FTDI drivers.  Still, I have never been able to get windows to recognize the APM plugged into my usb port as anything but an "unknown device."  Here is my setup:

    - APM 2.5+

    - 3dr Quadcopter kit (http://store.3drobotics.com/products/3dr-arducopter-quad-c-frame-kit-1)

    - Spektrum DX8 with AR8000 receiver

    - Windows 7

    - MP 1.2.57 / Mav 1.0

    - .Net Framework 4.0

    - directX 10

    When I power on the copter using a lipo, I hear 3 fast tones, 3 slow tones, and 3 fast tones and the props shake a bit.   The APM is showing me slow blinking red & blue lights.  I've bound the Dx8 to the AR8000, but I haven't been able to get the props to spin. I was hoping to use the MP to do some troubleshooting on the front.  I read something about arming the APM and I'm wondering if I haven't done that yet.

    When I connect the USB to my win7 machine that is running MP, the blinking blue/red light turns to a solid red light.  With or without the lipo plugged in, I see the same solid red light on the APM.  Unfortunately my win7 machine never recognizes the APM as anything but an "unknown device."  I've tried uninstalling and reinstalling drivers (although windows doesn't recognize the Ardunio Mega 2560.inf as a driver), I've updated directX and my .net framework.

    I'm at a loss.  Any suggestions would be greatly appriciated.

    --Nate

  • No good Martin

    Just cant get MP to see the hardware, I contacted the seller and they want me to post back the component for testing to see If I have broken it???

    Im over it already, I realy wanted this to work but stuffing around like this is very frustrating. There must be a better option than this, I just need to research it it better I guess.

    Im not a brilliant flyer and I dont see me being as good as others as my prime hobby something else and all wanted was a stable platform to film from. I need a quad where, if I let go of the sticks it hovers and holds position. So naturally I thought this was a good idea. It seems I just cant get past go after spending 300 bucks $%^$#@....

    I do appreciate everyones help and feedback though on this forum.

     

  • In windows 7 go to ... Control Panel ----> Hardware and Sound ----> Device Manager. If you expand the Ports (COM & LPT) is it listed? By the looks of your screen shots your drivers arnt installed. You dont need to use TPC in your mission planner when its connected with usb. It should have TCP, UDP and a third option with the coms port assigned in the device manager.

    Hope this helps.

  • T3
    John,

    Try uninstalling MP, reboot then install using the run as admin command and see if that does not fix it.

    Richard
  • T3
    Did you install the driver for the APM? When you connect your USB cable are selecting the correct Com port and baud rate?
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
Monday
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
Monday
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
Monday
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31, 2021
More…