Hello,

I am a high school junior and I am attempting to build an autonomous drone for my school project. I have little to no experience with drones, so I am only a beginner.

I am having problems connecting my pixhawk flight controller to Mission Planner on my PC. Whenever I connect, I get the "no heartbeat packet received" received error when mavlink attempts to connect to my pixhawk. 

Also, I had a successful connection to the pixhawk a few days back, and even today I can see the pixhawk detected under COM4 port, however, it refuses to connect. The pixhawk boots up fine and I am able to hear the successful boot up sound. I have tried restarting my computer, unplugging all peripherals, and trying multiple different USB ports/cables, but to no avail.

Any help/suggestions would be greatly appreciated!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I had the same issue. REsolved by connecting the Ground unit to laptop using FTDI. Then load settings in mission planner, as you would normally do with the air unit.
    Untick ECC & Op Resend. Save settings & try again.3702440078?profile=original

  • The same problem, Solved by formatting the SD card.

  • the fix for me was to load rover then back to tailsitter,he also fixed every thing else I could think of, amazing skill set, thank you Tridge...... this fixed my pixhawk, the explanation in duel motor tailsitters. 

  • I'm at a lose than.  It would seem the unit is defective.  Maybe a developer could point to the error sound that the unit is making and determine what might be wrong.

    Mike

  • I can see files on the sd card and I am pretty sure that it is properly inserted. There are two folders, Log and Terrain on the card. Log does not have anything in it. Terrain has some .DAT files in it.

  • Check that the SD card is properly inserted and if you have a computer make sure that you can see files on it.

  • I think it is the "armed" sound.

  • That's not good.  Is it one of these sounds?  http://ardupilot.org/copter/docs/common-sounds-pixhawkpx4.html

    Sounds (Pixhawk) — Copter documentation
  • The port and baud rate are set as you said. The center led is yellow solid not flashing. The other lights look are as you said. When it starts up I hear a long beep.

  • In Mission Planner in the pull down list of com ports it says: COMX PX4 FMU (COMX). baud is 115200.

    On the Pixhawk you have yellow flashing led in the middle and the back 5 LED's has two yellow led's on and on the left one blue led flashing?

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…