Replies

  • Anyone else knowing how to make the servo move the full 90 degrees?

  • Make sure that on the gimbal page you have a full range like -90 to 90 or 0-180

    Then you may have similar range limits for the gimbal controller itself. Check that in the Gimbal Controller software.

    • The default values there were -45 and 45

      I tried with -90 and 90, but that didn't change anything. Will have to try with 0 and 180

      there is no gimbal controller, just a servo connected to pxhawk out 1

  • Hi there.

    You have to change, in the Mission Planner, the RCN_MAX value and the RCN_MIN value in the Full Parameter List from the CONFIG/TUNING sheet, where N is the OUT Port where your Servo is connected.

    Regards

    Esteban

    • Yes they are set to 989 and 2014 respectively. That is what the radio calibration min and max shows.

      Still only 90 degrees movement of the servo.

      huh

      edit:

      RC9_TRIM is set to 1500

      What does that mean?

  • Look back on the gimbal control page and you will see some adjustments for range.

    • I see just angle limits, which doesn't seem to affect anything.

      I tried with various values.

      I'm with the APM GS

This reply was deleted.

Activity

Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…