Pixhawk and Graupner MZ24 / GR24 PPM problem

Hi,

I am trying to get Pixhawk talking to a GR24 receiver using PPM but when it is connected, and the receiver is set with SUMO 12, I connect port 12 on the GR24 to RC IN on the Pixhawk (arducopter 3.1) but nothing comes through on the radio calibration screen. had anyone got any idea why that might be?

thanks.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I have the latest firmware 1.021 and been through a lot of settings in the SETTING & DATA VIEW but I cannot get Failsafe work when SUMO is used for the Pixhawk. If I connect a servo to the GR-24 ch3 it will follow the Throttle position and will turn to Failsafe position when transmitter is powered off but it doesn't change the Throttle settings seen in Mission Planner and the Pixhawk doesn't go into Failsafe mode.

    Andre K: Would you please explain how you have solved it?!

    Thanks
    Anders

    • PPM data have it's own failsafe configuration stored in RX,    select "setting & data view"  (I think you use ESC to get there fastest)  , goto RX-Failsafe , set fail safe to OFF(not hold anything else) , this ends PPM stream if connection is lost.

      BTW, it's your RX firmware that decides what options you'll see there.. 

      • My setup looks like this:
        RX FAIL SAFE V3.75<>
        OUTPUT CH: 03
        INPUT CH: 03
        MODE: OFF
        F.S. POS: : 1000usec (The lowest I can set)
        DELAY: 0.25sec
        FAIL SAFE ALL: NO
        POSITION: 1342usec (Current throttle stick position)

        It still doesn't work

        Please help
        Anders

        • Just reading your last line...

          I will upgrade my GR-24 to the latest software later today and give a response here.

          Thanks
          Anders

          • and one more thing, In case you are using Arducopter 3.2 or older (not a fresh build)  - it does not show PPM loss unless armed.   - you may flash ArduPlane and see it works just fine.

            I don't think you'd see the OFF option if your RX firmware did not support it already.

            • Wow! It works.

              I expected it to show on the bars in Mission Planner -> Initial Setup -> FailSafe but it does not!
              The easiest and probably the best way to test is to power the Pixhawk over USB and use Telemetry for Mission Planner.
              I had to change FS Pwm to 1050 to achieve RTL.

              For testing with propellers, don't connect battery. Power the Pixhawk over the micro USB port.
              Wait for the Arming check to finish and press the safety switch. The Pixhawk will not arm unless you press it. Now set mode to Stabilize and "Arm" with the transmitter. Give some throttle. Watch Mission Planner Flight Data.
              Power the transmitter off and watch the mode set to RTL
              "FAILSAFE" is written in red and "NO RC Receiver" also.

              Anders

  • If you read previous posts you'll see that you should use port 8 of the GR-24!

    SUMO 12 tells the transmitter to send ch 1-12 to the SUMO port on the receiver.

    In Mission Planner you can look at Radio Calibration page to see that all stickers and switches do what you want.

    • Thanks Anders,

      I sorted that issue out.

      do you have any experience in making the receiver bring throttle channel low on signal fail?

      regards

      • you must read the manual, and releasenotes.

        If you have the latest Graupner firmware release, you can (and should) decide what PPM will do;  go away (good) , output failsafe (can be good, if you configured it correctly) or hold (dangerous)

        This is in RX config, not the usual failsafe config screen.

  • Hallo,

    I've also connect between RC port on the Pixhawk, and port 8 on GR-24. But nothing comes on my Radio Calibration. Help please...
This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
More…