Pixhawk Arm switch bypass

Hi Guys

Version 3.2 firmware is supposed to have this i understand but i cannot see anything in the Github repository i was pointed to. 

No sign of release version either yet.

I want to see if this gets me past my Esc calibration issues but it looks like i might have to come up with another plan.

Does anyone have any info on the arm switch bypass either way please ?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I can't find this parameter in 3.3.1?

  • You can disable the safety switch by setting the BRD_SAFETYENABLE parameter to 0.

    Link is here.

    • I have a PixHawk running ArduCopter 3.1.5

      I can find the BRD_SAFETYENABLE parameter. I dumped all my parameter list into a file but I could not find BRD_SAFETYENABLE in it. Do you have it in your parameters ?

      • It was not in 3.1.5 but i decided to try 3.2 rc3 on monday and there it was.

        As it happens it did not help with calibrating my Esc's, perhaps there is a technique i am unaware of. I have succeeded is calibrating them one at a time now though.

        • Setting BRD_SAFETYENABLE to 0 is the only way to arm some ESC..

          I fought with this for a while...  Good job putting that in there

          Eddie Weeks

    • Hi

      Thanks, i have loaded the relevant firmware and have set the parameter to 0. Will test tomorrow that i can calibrate the Esc's.

      Fingers crossed

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…