Pixhawk: can't calibrate external 3dr compass

Hi, I have problems to calibrate the external 3dr compass with my pixhawk.

Using Mission planner l select Pixhawk/PX4 and try live calibration.

I see for compass 1 and 2 error 99 and never more then 3 samples are collected.

The behavior is very similar to this one

http://diydrones.com/forum/topics/pixhawk-compass-calibration-does-not-work

A little bit more story.

First I bought a pixhawk together with an external 3dr GPS/Compass.

With this compass I could calibrate with no problem and GPS was also working.

But the compass seems to have an issue. When the pixhawk was running a while (e.g. > 10 minutes) the heading began to turn around faster and faster over time.

I calibrated the compass many times but this behavior always came back.

So I send it back and got a replacement.

Here I want to notice that the shipped 6 pin cable for this new GPS/compass for gps was a 6 to 5 pin cable.

I was a  little bit wondering and used instead a 6 to 6 pin cable.

With this new module live calibration isn't working.

I couldn't believe that this new module is not working and bough an additional module (which was shipped also with 6 to 5 pin cable).

Unfortunately this 3rd module is now also not able to be calibrated.

So what going on here???

I tried many things including flashing new firmware to the pixhawk, replace the I2C cable, replace the GPS cable but with no success. (calibrating the pixhawk internal compass works).

I also checked the pixhawk I2C supplied power and measure there around 4,7 V. Is that normal?

Could it have to do with a bad batch of these 3dr modules?

I bought them in Germany and because my both last modules were shipped with this wrong 6 to 5 this could be the case? Or it's me causing the problem? :)

Any hint what I can try to get it to work?

I'm really disappointed!

Cheers

Pat

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Maybe the compass came in contact with a magnet and got degaussed somehow. There is a trick to repair this, but i only seen it with the DJI compass modules, although in escense they are very alike.

    You can check the video for reference...

    • Thanks for your reply Andreas but I don't think that this applies to both of the new compass modules. And I assume that the store isn't so stupid to place mangetic things near by the modules. :-)

      • well maybe by accident it did. And, by any chance, did you put it near  strong magnetic field.

        • I'm sure that this didn't happened from my side but I will take your hint into consideration if no one other has another idea what could be wrong.

          • Basiclly if all the circuitry is ok, then its just that the sensor is out of his standar operating parameter.

            Try sending it back to your provider as well, if it is just nwe, well just say that it came faulty

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @breadcentric: The handy bit about racing with self-driving cars is that one can type while the car is racing. Report from #AWSDeepRacer…
yesterday
DIY Robocars via Twitter
RT @chr1sa: Our Bay Area @DIYRobocars meetup is now at 2,700 members. Next in-person events (in Oakland) are training day on July 17 and…
yesterday
DIY Robocars via Twitter
Videos from the ICRA autonomous racing workshop are now available: https://linklab-uva.github.io/icra-autonomous-racing/
Jun 10
DIY Robocars via Twitter
RT @SmallpixelCar: Prepared race track for Warm Spring Raceways @wsraceways and looking forward to test my new car at RAMS RC @ramsaicar fa…
Jun 6
DIY Robocars via Twitter
RT @f1tenth: Trying out some nasty blocking maneuvers 🏎️🤖 #f1tenth #autonomousracing https://t.co/nMTstsaogM
Jun 5
DIY Robocars via Twitter
May 27
DIY Robocars via Twitter
RT @araffin2: I will talk this Saturday from 18:00 to 19:00 Paris time for the @diyrobocars community about learning to race in hours using…
May 27
DIY Robocars via Twitter
RT @a1k0n: Luckily the infeasible hairpin problem was easily reproducible in simulation and I could test the fix before bringing the car ba…
May 26
DIY Robocars via Twitter
RT @a1k0n: Another problem was that I was over-constraining the car's allowed accelerations, so it didn't think it could turn as tight as i…
May 26
DIY Robocars via Twitter
RT @a1k0n: Breaking the map up into two halves worked, but I had to be more careful about separating the inner track from outer. There's se…
May 26
DIY Robocars via Twitter
RT @a1k0n: Here's a datalog for my fastest lap of the day. Lap timer is tiny window lower-left. https://t.co/myrlWWrKUY
May 26
DIY Robocars via Twitter
May 26
DIY Robocars via Twitter
RT @a1k0n: Here was my car's POV. Man this track is confusing in first-person! After the incident my camera was all scuffed up and I was af…
May 23
DIY Robocars via Twitter
RT @circuitlaunch: Loved seeing so many familiar (masked) faces at Circuit Launch today for our first in person @diyrobocars in over a year…
May 22
DIY Robocars via Twitter
RT @circuitlaunch: Last but not least, mystery guest @BostonDynamics Spot took to the track @diyrobocars He enjoyed the #brazilianbbq too 😂…
May 22
DIY Robocars via Twitter
RT @SmallpixelCar: Today’s race @circuitlaunch for @diyrobocars with @a1k0n Was busy in the morning and did not get a chance to tune camera…
May 22
More…