Pixhawk causing motor sync issues.

I believe I have a problem with my Pixhawk and was hoping for some help.  Also posted this on rcgroups.

The issue is that when my speed controllers are hooked up to the Pixhawk they exhibit a bad sync issue.  However when they are connected to my old APM (3.1) or just a receiver directly they do not exhibit these symptoms.  This has resulted in 4 crashes now until I just tonight narrowed down the issue to the Pixhawk.

Can anyone advise what is going on?  Here are the specs of my setup:

Afro 30A ESC's with SimonK firmware (have tried all versions, and made my own with various parameters)

Tiger MT2216-9 1100kv motors

4S 3700mah battery

https://www.youtube.com/watch?v=i7_gVoY8q8M

https://www.youtube.com/watch?v=VTK81IANyUE

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

        • Thanks ever so much OG... Much appreciated... Cheers and Safe Flying!

  • Can anyone confirm or deny that RC_SPEED goes "back" to standard (380 Hz as I remember was standard) when PixHawk is set into AutoTune mode???

  • I wish I had a log on this, but it was not enabled :(

    Now I have just got some new Tarot arms, and new ESC ZTW Spider series 30A with SimonK

    http://www.banggood.com/ZTW-Spider-Series-30A-OPTO-Brushless-Speed-...

    If it does the same thing with new ESC and arms, I'am thinking about having a bonfire with at my local Danish RC-Club and burn the freaking PHawk before if costs me any more money... :D

    • Same issue; it costed me a Gimbal, new ESCs, changing motors, but still having issues.... I gave up on BLHeli, rebuild the copter; and now with SimonK and still having sync issue on Arming; and I have to recalibrate the ESCs every time before taking off, and it flies... But seriously not reassuring, Lads! 

      I really feel desperate, especially as no one is sharing their BLHeli settings.... It's been 2 months of trouble shooting... Never had such issues on APM or any other FCs, and we have build quite a lot of Copters in the past few years; and this PIxhawk, is seriously a pain! HEELLPPP GUys, please; we are too many for it to be just us! There is a problem somewhere else; come on!?

      • I'm no expert but as I understand it blheli settings are more dependent on the motor/prop rather than the flight controller.  So settings can be very different depending on which motor you have.  However, pretty much all desync issues i've heard of are on low-kv motors.  You've got relatively high-kv motors so desync shouldn't, theoretically, be a problem, as far as I know.

        BTW I ran 920kv (DJI E300) motors with afro 20a slims ESCs with blheli for many flights with zero problems using standard default settings.

  • There is no way that can be caused due to magnetic field interference, it was flying fine isn't it.

    A bad mag heading would cause a fly away or a ekf compass error....this definitely looks like a sync issue. Logs please   

  • Allright new update... As mentioned, I had some luck getting the thing off the ground after I set RC_SPEED to 100...
    After that, I configured my Auto Tune.
    I lifted off the ground, and got it to a steady position, in Alt Hold mode, switched on the Autotune and the thing twisted straight into the ground, crash!
    My own theory is that as soon as I switch on autotune, pixhawk ignores the RC_SPEED 100 and goes into some standard mode, and back to original RC_SPEED, which I think was 380.

    Here is the video:

    https://youtu.be/94WaCmswCcs

    • It's not unexpected to invoke sync issues in autotune as autotune deliberately does lots of very sudden high throttle movement - classic way to invoke desync.

This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Jan 12
More…