Gents I need your help.

I recently upgraded one of my 2.6APM powered quads to a Pixhawk.  One of the reasons I went ahead and did this is because the Pixhawk is supposed to take PWM RSSI signals directly (into the Sbus port aka Pin 103) and I could ditch my PWM to analog conversion circuit is used in my APM.

I have verified that my EZUHF receiver is outputting RSSI in PWM form on one of the channels. (it will move a servo appropriately when the RF gets weak or disappears... and it worked fine for the APM as an RSSI input via a PWM to analog conversion circuit)

And, I have hooked up the PWM RSSI output to the Sbus port (pin 103).... it does nothing.  Shows zero RSSI on the OSD no matter what.

I can't find any useful description of how to configure this in the wiki, mission planner or this site.

How do you make a Pixhawk show RSSI from a PWM input on pin 103 as its advertised?

Thanks for your help.

Steve

Views: 20230

Reply to This

Replies to This Discussion

Hi Did you ever solve this?

I have a PIXHAWK and a Futaba T8FG and would like to buy a EZUHF for the futaba and then a 4CH RX or the 8CH diversity and use the PPM. Only it will suck to pay 260+ bucks and not have it work. 

There is an easier way. I have a EZUHF and see RSSI on my minimosd but i have a APM. The trick is to config the EZUHF rx to send the rssi as PWM over a channel. It doesnt matter which, just pick one of the high ones like 5 - 8. The APM wont know its RSSI it will think its just another regular channel.

You can config this using the Immersion config tool. You can then config minimosd-extra to read rssi over that same channel. The minimosd-extra config tool has this option available.

The only downside is that you lose a channel between the rx and the apm. However i still have 8 channels coming thru i simply connect one directly to my gimbal to control the tilt. I thus end up with 7 + the rssi going to the APM and one from the rx to my gimbal.

Its simple and works, no extra hardware or fancy analog to digital converter type bits.

Good stuff, minimosd-extra is always evolving, its always worth grabbing the latest of all the artefacts and trying them because new stuff is always appearing.

Does anyone know if or when the RSSI over PWM feature will be delivered?

Hi Steve,
Wow, the hours I have worked to get RSSI from my pixhawk ( plane, not copter ) on my minim OSD !
And as of today, still no luck.
I have been following this thread and have followed all of the steps to achieve RSSI from my Pixhawk to my minim OSD.

On the minim CT , I set the rssi pin to channel 7, (and accordingly set the RSSI ppm output channel on the receiver to 7 as well )
Rssi is still reporting a non changing value of -99 on the screen , regardless of the transmitter being on or off.

I checked the actual output of the rssi by connecting a servo to the no 7 channel and the servo moves when the rssi changes, so I know channel 7 is outputting a proper pwm signal representing the rssi.


Is there something else you did in MP to effectively get the pixhawk to "see " the rssi ?

On MP, I tried setting the RSSI pin parameter to " pixhawk" (103) ,nothing. Tried typing in A7 for analog pin 7,nothing. Tried the other "A" numbers in the drop down box, but no changes.

I am 5 plus hours into this and completely baffled. Your help would be GREATLY appreciated !!

Mark

Just had the same issue - APM 2.5.2 and MinimOSD - looks like on CH7 the RSSI is not working in MimimOSD, on CH8 it works though. EZUHF, PPM Muxed, RSSI on CH8. Only problem now is that its reversed ...

Thank you for the quick response ! I will try changing to channel 8 , and hopefully get some results ...thx again.

I found that ezuhf RSSI has a pwm range from about 990 to 1600 - but inverted so 100% is no signal an 0% is full signal.

Using ezuhf LINK (link quality) the pwm range is 1050 go 1790 and gives 0% for no signal (transmitter turned off) and 100% for full signal

would be great if the reading could be inverted in the config tool. I tried giving the higher pwm value as min and the lower as max but this does not work.

Thanks again for your help Steve. I have it performing on the bench as per the RSSI extremes , that being the 900/1600 pwm metrics. I flew it this afternoon and experimented with the RSSI failure points by putting the EZUHF into attenuation mode ( switching from hi to low power while holding the bind button down ) and then flying out low (400 feet )about 1/2 mile in auto mode. The rssi got to about 30%, but did not trigger failsafe. I found by gripping the EZ UHF antenna with my hands at the 3,000 foot mark, , I got the rssi numbers up to around 50 to 60%, and around at 65 percent DID trigger failsafe. I repeated it three times , and would say 65 percent is where rssi is going to indicate failure. I will try , as you suggested, the link quality metrics tomorrow and report my findings. Thanks again for your help !
Does this work?
Going to try

I've tried all of the above but can't seem to get it working.

I am using the 2.4r727 config tool and have flashed to firmware 2.4r726.

Hi Steve!

Would you mind posting a pic or showing me how to plug the Pixhawk with EZUHF 8ch diversity?

I've set ezuhf via USB to work as PPM through CH1; however, I'm able to power up the receiver but when I try to bind, I push the bind button, it goes off and never comes back on.... :(

Am I suppose to connect the ezuhf to RC in pixhawk or SB pin 103?

I would really appreciate your help...

Thanks

Javier

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service