Pixhawk will not arm

Until I updated to the the latest stable firmware for quads, my Pixhawk worked flawlessly. When it would not arm, I changed the arming check to "0" (zero, not O or o), wrote the parms to the board, but the Pixhawk still will not arm. All the lights are normal for prearm. Green main led, steady red safety button. The flight data page reads, "disarmed, Stabilized, 3d Fix, 16.5 v. When I pull the yaw stick down & to the right...silence. I changed the arming check back to "1," but same story. I tried several times to recalibrate the esc's, but ...silence.

I successfully recalibrated everything multiple times, but nothing changes. 

Any ideas why it will not arm?

You need to be a member of diydrones to add comments!

Join diydrones

Replies are closed for this discussion.

Replies

  • Also will not arm in some "flight modes".
    Besure your transmitter switches are set "stabilize-mode".
  • Do a test, in stead of moving left stick down and right, move it down and left. If it arms, then you need to reverse the channel 

    Also, on the pixhawk you have a safety button you need to press before arming. 

    • Johann, thank you for your quick reply.

      Yep, that's what I had to do with my tricopter setup. I had to reverse the channel to arm correctly. I did try down & to the left on this quad/Pixhawk setup. It works no better than down and to the right.

      I understand the safety button. It flashes red until time to arm. After pushing the button, I get a steady red light, Everything looks normal...but silent and still.

      It worked before the firmware update. The quad & Pixhawk flew great. Rock solid. Predictable. Sure wish I had waited several months to update the firmware. Should have let the bugs be worked out.

      If you can think of anything else to try, please let me know.

      • 3.1.5 copter.

        I tried to go to an earlier version in MP but could not figure out how to do it. Is there another way?

        • I have not been able to figure out how to do it on APM Planner 2.0. I'm using Mission Planner 1.3.9 and it has the function to load previous firmware.

          Go to initial setup and then click Install firmware 

          At the bottom right, there is an option to load previous firmware. See below 

          3702764737?profile=original

          Once you clicked it, it will provide you with a dropdown box from where you can select the firmware you want to load.. Once selected you just click the picture at the top for which vehicle you setup you want to load .. 

          • Thanks, Johann!!! I missed that. I'll let you know how it turns out.

            By the way, where are you located?

            • You are most welcome. 

              I'm in South Africa

              • 3702899046?profile=originalI have no clue as to which firmware to choose. It appears that there are versions for hexes, tri's, ect. I tried to look it up by clicking on the "download firmwares" icon, but that really gives a lot of confusing choices. Seems that the previous version was 3.01, but it is unclear what differentiates the quad firmware from the others.

                drop down list.jpg

                https://storage.ning.com/topology/rest/1.0/file/get/3702899046?profile=original
                • For some reason I cannot reply to you last post so I'm doing it here. 

                  What happens when you try to upload a much older version?

                  Sorry I don't have a pixhawk, I have the APM so i'm not sure if it's a possible to load an old version of firmware on the pichawk. I can't see why it would not be possible. 

                  Perhaps ask one of the Devs. It might be something simple that we are missing here.

                  • Okay, I'm brain dead. Switched the new Tx from mode 1 to mode 2. Arms and motors spin.

                    Johann, thank you for your help.

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…