My Pixhawk boots fine when powered by the power module only, but when I connect 5V to the servo/motor output rail, it doesn't boot but just makes clicking sounds instead. 

Video demonstrating the problem:

https://www.youtube.com/watch?v=jODj9UzkG1Q

The 5V being supplied to the servo output rail comes from a J&K Universal Power Distribution board with built in 5V and 12V regulators. I measured the 5V regulator output to be 5.00V exactly on my voltmeter.

If I connect the 5V to the servo output rail after booting, then it works fine too.

My wild guess is that it's a timing issue at power up, e.g. if one of the power inputs get's power a before the other, then the Pixhawk freaks out.

I tested it with a different 5V regulator afterwards and then it did boot. But that doesn't explain why it doesn't boot with the power distribution board's regulator.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Mine was working fine when all of a sudden it stopped booting and is making the crickets sound. I did try to plug it in with a 5V power instead of the USB into my computer



    James said:

    At least you have a situation that is working and not working...Currently the only situation I can find on mine is the 'crickets'.  Slowly losing my mind trying to remove all the connectors and narrow it down.  I will see if I add a capacitor on it what happens...but super strange to me that it just started doing this.  

  • The crickets sound is probably (my guess) the power input selector switch that can't make up it's "mind" about which input to use resulting in the Pixhawk not booting.

    I did get the crickets sound a few times with my LC filter too, so I switched to a different 5V regulator and so far it's working fine. I did report the issue to 3DR long ago, but haven't received any feedback/help so far, even though I'm using original 3DR hardware.

  • At least you have a situation that is working and not working...Currently the only situation I can find on mine is the 'crickets'.  Slowly losing my mind trying to remove all the connectors and narrow it down.  I will see if I add a capacitor on it what happens...but super strange to me that it just started doing this.  

    • Any luck James? I was flying fine yesterday but today my Iris+ gave a low battery failsafe beep when plugged in via usb. I unplugged and plugged back in, now I only get "crickets". No led, no beep, only clicking. Scared to plug battery in. I would really like to hear from someone who has ID'ed the clicking sound first.

      • So I don't know exactly what went wrong, but we checked the voltage on the 5V rail and it was only ~3, so you should check that voltage as your first step to see if you were similar to me.  After discovering this and working with tech support, they said they can't do anything for me, and the board is done.  Offered me 15% off a new board purchase...I decided to go with a different flight controller. 

  • Update:

    Because I suspected it has something to do with the sequence at which the power module and the UBEC for the servo rail reach their full voltage (5V), I added an LC filter after the UBEC to slow it down. If I do that, then the PixHawk does boot.

    I'm not one of the lucky few who own an oscilloscope, so I can't analyse in detail what's going on/wrong, but hopefully somebody can figure it out.

    B.t.w. it can't be an initial voltage spike, because I'm using a 5.3V zener diode between the + and - rails.

    • Update:

      Even just adding a 6.3V 220uF capacitor over the main output rail is enough to make it boot.

This reply was deleted.

Activity

DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
RT @_JonMyer: 🚨Attention DeepRacer's including #UndergroundDeepRacer🚨 Check our our LIVE stream that including @IAM_dbro Take a few moments…
Aug 5
DIY Drones via Twitter
RT @MarvelmindMaxim: Extreme precision for 60 swarming robots. #marvelmind #autonomousrobotics #robotics #swarmrobotics #rtls #ips #indoor…
Aug 3
DIY Drones via Twitter
RT @MarvelmindMaxim: Precise (±2cm) tracking for racing boats and autonomous boats. Works outdoor and indoor. #autonomous #AutonomousVehic…
Aug 3
DIY Drones via Twitter
RT @MarvelmindMaxim: Helping PixHawk folks to fly autonomous quadcopters using PX4 and ArduPilot. https://marvelmind.com/drones/ Equally suitab…
Aug 3
DIY Robocars via Twitter
RT @chr1sa: The @DIYRobocars @donkey_car virtual AI car race is starting in 15 minutes! Watch it live on Twitch https://www.twitch.tv/mossmann3333 htt…
Aug 1
DIY Robocars via Twitter
RT @chr1sa: Don't miss our monthly @DIYRobocars @donkey_car virtual AI car race tomorrow at 10:00am PT live on Twitch. Head-to-head racing…
Jul 31
DIY Robocars via Twitter
RT @sparkfun: Our completed tutorial on building an @NVIDIA Jetson Nano-powered @Sphero RVR gets your bot up and running via teleoperation…
Jul 30
DIY Robocars via Twitter
RT @SmallpixelCar: Freeway test https://t.co/4V5tV9lhIP
Jul 29
DIY Robocars via Twitter
Very small autonomous cars racing, thanks to an overhead camera: https://control.ee.ethz.ch/research/team-projects/autonomous-rc-car-racing.html
Jul 29
DIY Robocars via Twitter
Jul 29
DIY Robocars via Twitter
Jul 29
DIY Robocars via Twitter
RT @chr1sa: Don't miss our virtual AI car race this Saturday! Real developers + virtual cars =🏎️🏎️🏎️ Head-to-head battles with thrills, sp…
Jul 28
DIY Robocars via Twitter
Jul 27
DIY Robocars via Twitter
RT @usashirou1: Jetson nano by Isaac Kaya #jetson https://t.co/Mu1N0CyQkN
Jul 23
DIY Robocars via Twitter
RT @GPUsolution: JetRacer mady by Iflytek company #JetsonNANO #Nvidia https://t.co/MimTymIwge
Jul 23
More…