Problems uploading firmware to the APM 2.6

Hi,

I'm doing a first time set up for my 3DR Quad using an APM 2.6 board. I've managed to install the Mission Planner software and the device drivers for the APM. I've set the baud rate to 115200 on both the Com port and in MP and selected the correct Com port in the MP drop-down menu (the MP drop-down doesn't show the APM - only the port number?).
When trying to install the arducopter firmware, it goes through the process of connecting with the APM and then starts downloading the Hex file. I then get a "failed upload" prompt with an error message "Communication Error - no connection".

I've tried using a powered USB hub in case my USB voltage wasn't sufficient, but still have the same problem.

Does anyone have any idea on how to resolve this issue?

Thanks

Ian

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Problem solved - Turned out to be a Windows 7-USB issue on my laptop. Still not sure what is causing the problem, but at least my copter is flying!

    • Hi, Ian. Do you know what was the problem?
      I'm having a very similar one, but with the Pixhawk board. Tried in two computers, changed cable, still the same error.

      Thanks in advance!

      • Hey Seidi,

        I discovered it was a computer specific problem which I never managed to solve. I managed to get the firmware updated using another computer. I've also recently updated the firmware to my new pixhawk FC with no problems (on a different pc). Sorry, not much help, but maybe try another computer with different operating system and see if that helps.

        • Gonna try to update the firmware in another computer. Thanks anyway, Ian.

This reply was deleted.

Activity

DIY Robocars via Twitter
Sep 9
DIY Robocars via Twitter
RT @chr1sa: We've got another virtual @DIYRobocars race tomorrow at 9:00am PT. Two dozen autonomous cars will compete, four at a time. Ther…
Sep 4
DIY Robocars via Twitter
Sep 1
DIY Robocars via Twitter
Aug 31
DIY Robocars via Twitter
Aug 31
sam liked Jimmy Oliver's profile
Aug 25
DIY Robocars via Twitter
RT @ExplorerRobocar: Sometimes, I am really a big kid!! Having fun with my virtual RC car on the @diyrobocars track 😜😉, by using the « AR R…
Aug 24
DIY Robocars via Twitter
RT @grepLeigh: @donkey_car @unity3d @TensorFlow ~1050 episodes into training, my agent learned to erratically drive in the left lane. 🤖😆 ht…
Aug 24
DIY Robocars via Twitter
RT @EclipseCyclone: Sweet! http://Robotec.ai high performance #ROS 2 @unity3d #CycloneDDS bridge for @AutowareFdn @SVLSimulator now…
Aug 24
DIY Robocars via Twitter
RT @a1k0n: My car had a lot of trouble getting around the track at the last @diyrobocars event -- only one actual finished lap during the r…
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map https://t.co/VzykOkUt2G
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: Made a lot progress on Warm Spring Raceways track. Almost finished one lap. https://t.co/nUVpufZQyP
Aug 24
DIY Robocars via Twitter
RT @AntonioRobotics: Super fun time seeing these autonomous cars race at @circuitlaunch for the @diyrobocars quarterly meet up! The demolit…
Aug 15
DIY Robocars via Twitter
RT @a1k0n: I thought my dumb localization code was still working at the new @circuitlaunch track, but it was just *barely* working. I shoul…
Aug 14
DIY Robocars via Twitter
RT @DAVGtech: Recording of entire in person @diyrobocars race today @circuitlaunch. Fast forward a couple hours to go straight to the racin…
Aug 14
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map. Very noisy Lidar signal https://t.co/bAbeVUMi10
Aug 14
More…