I am on the latest code and have managed to mix my Hitec tx with two channels to give me at least five flight modes.

 

Hovering in Stable mode is fine but when I select height hold or loiter, the qaud flies aggresivly off at an angle as though it needs to go somewhere fast.

 

I now hold it in my hand and when I select these modes, all motors seem to go to to full throttle.

 

Does anyone have any idea what the problem is.  I have only altered the PIDs for stable mode and haven't touched anything else.

 

I know that this stuff is early beta but I'm sure that the team wouldn't release the code if this were a known issue.

 

BTW - comiserations to the guy who lost his quad in the last few days due to issues with the latest code.  I imagine that it just flew away out of control......

 

Philip

 

 

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • its not vibration damper I reloaded firm ware now in stead of rise it falls I have another that once you move the stick past middle it goes full throttle in alt hold just holding in my hand no props I had one fly away never to be found  I think its setting a glitch some where be cause I had one that was perfect same setup

  • You should Install vibration damper for z axis vibration
  • did you find the answer?

  • Hi Patrik,

    I really liked your approach and I am using it in my setup. Thanks for the detailed information provided.

    Question, since you have setup RTL on the trainer switch I would assume you have to hold it until it lands in order to operate properly, otherwise it will go into the previous set mode, right?

  • Yes Wilson Channel 5 is the one

    • Thanks. Excuse the delay. I Solved. Maybe I'm going to put a video on you tube

  • This is very  helpful but I'd appreciate it if you clarify which is the channel that transmits flight mode to ArduPilot (CH5?)

    Thank you

  • Developer

     

    It's very simple to get 6 modes with Hitec. Just use a mixer without mixing rate, only offset setting.

     

    Finding this took me about five minutes, two days after buying an Aurora 9. The touch screen is really helpfull to experiment such things.

     

    Here is how for Hitec Aurora 9 : (it's a scoop as i didn't see this tip elsewhere on Internet) :

     

    1) Define channel 5 as Aux 1 channel with a three position switch like E

     

    2) Adjust the CH5 (Aux1) subtrim to something like -20 (subtrim inside menus)

     

    3) take a free mixer, and set it like this :

     

    source channel : nothing

    destination channel : AUX1

    Rate : 0%

    OFfset : +45%

    ACC : 0 %

     

    Mixer Switch : assign a 2 positions switch like G.

     

    3) Eventually adjust a bit those value, checking with the radio test in the CLI, then Enjoy your 6 modes.

     

    You need to be near those values :

     

    1165    pos0

    1295    pos1

    1425    pos2

    1555    pos3 -> default for no PWM signal (usefull with Aurora 25 secondes second failsafe)

    1685    pos4

    1815    pos5

     

    The very nice thing with Hitec is that you don't waste a receiver channel. The mix is done internaly in the tranmitter.

     

     

  • Phillip,

     

    Could you share how you set up your HiTec? I have a an Optic6 and want to use it for my quad. I will have no GPS or Mag. to start.

  • Moderator

    " I have only altered the PIDs for stable mode and haven't touched anything else."

    That will be a problem. The altitude PIDs will need tuning as well based on your quad's weight and power...

This reply was deleted.

Activity

sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
More…