RFD900, RFD900+ - New long range radio modem

Hi All,

I would like to introduce you to a new radio modem that we developed for very long range datalinks!

http://rfdesign.com.au/RFD900.php

Some of the key features of the RFD900 are as follows:

  • Multi point and point to point link capability.
  • Long range >40km depending on antennas and GCS setup.
  • 2 x RP-SMA RF connectors, diversity switched.
  • 1 Watt (+30dBm) transmit power.
  • Transmit low pass filter.
  • > 20dB Low noise amplifier.
  • RX SAW filter.
  • Passive front end band pass filter.
  • Open source firmware / tools, field upgradeable, easy to configure.
  • Small (30 x 57 x 13 mm), light weight (14.5g).
  • Compatible with 3DR / Hope-RF radio modules.
  • License free use in Australia, Canada, USA, NZ.

 

These modems are designed to support long range applications, while being easy to use and affordable.  

These modems have been flying in various platforms and have demonstrated excellent performance in real applications. 

RFD900 modems are now available at: http://store.rfdesign.com.au

Support within APM planner and the radio configurator from Michael Oborne is already available.

It works seamlessly with APM planner, all radio Mavlink parameters are available.

Update, December 2014:  The RFD900+ with improved specifications is available now at:

http://store.rfdesign.com.au/rfd-900p-modem/

Seppo Saario

rfdesign.com.au

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Also, close together isn't necessarily good.. when I first connected my pair, I couldn't figure out what the problem was... once I separated them by about 15 meters, the connection was perfect. This, of course, may not be the case in your situation, but 'tis something to consider.

    Thijs said:

    Hi Seppo

    While trying to connect, I get a poor link quality, while the rssi, remote rssi are quite high (>210) and the noise levels are quite low <80.

    Still, I get a poor link quality, which varies anywhere from 8 to 35%. The remote radio and boat are about 2m separated in my workshop, so the distance is not an issue.

  • Hi Thijs,

    Try to use the MPSiK V2.5 rfd900p.ihx firmware from http://files.rfdesign.com.au/firmware/

    It will work better

    http://files.rfdesign.com.au/Files/firmware/MPSiK%20V2.5%20rfd900p.ihx
  • Hi Seppo

    I recently bought anRFD 868+ set to link a ground control station (using mission planner v1.3.4( to a boat (using a pixhawk and ardurover (v3.01) to control a RC boat. 

    While trying to connect, I get a poor link quality, while the rssi, remote rssi are quite high (>210) and the noise levels are quite low <80.

    Still, I get a poor link quality, which varies anywhere from 8 to 35%. The remote radio and boat are about 2m separated in my workshop, so the distance is not an issue.

    I have powered the remote radio (in the boat) using a separate 5V BEC to make sure that there is no voltage drop while transmitting at high output levels. Anyway, I've tried to reduce the output power from the standard 100mW to 10mW, but that didn;t make any difference.

    Attached rssi.png which shows the rssi and noise levels. There are no rx errors, see errors.png.

    The radio settings are kept as default, see radio%20settigns.PNG.

    I have checked the difference if I set ECC or OP RESEND on on both radio's, but that doesn't make any difference. 

    Do you have any idea's what may cause the poor link quality? It varies day by day. Sometimes it is not more than 7%, other days it goes all the way to 35%. I even had 100% for a few seconds while switching it on, but so far the quality is rather poor, such that the mission planner flight controller (the connection) is so slow that it can hardly be used. 

    Thanks for your help!

    radiosettigns.png

    errors.png

    rssi.png

  • Any updates on the rfd900X?  I've been waiting on ordering some modems since I saw they would be released "soon" last spring.

  • Thanks for the link John,

    Don has given me some suggestions, but still no joy in complete fix. I have managed to get the telemetry data working between ground modem and air modem, however, as soon as I turn on my Taranis radio, I get a "communication lost, communication regained" error repeating so there seems to be some interference happening now with the 2.4ghz radio.

    Any thoughts on that issue?

    John DeVere said:

    Glen, take a look here on the QGroundControl support forum.
    I found a post exactly like yours.
    https://groups.google.com/forum/m/#!topic/qgroundcontrol/0soE0y8qyXw
    -John


  • Seppo said:

    Hi John,

    Have replied to your email.. Arranging a replacement for you.

    For the record, I received a replacement the next day and all is well!
    Thank you so much
  • Thanks for the suggestions guys! I don't like to spam forums, but it's nice if someone is able to help you out.

    Paul beat me to the reply. I actually saw the terminal tab within 3dr interface after a while (which I didn't know of before) and gave it a shot, and now wanted to mention here that it worked. (I did however repeat the firmware upload step also, to ensure that nothing's "screwy").

    Thanks for everything. I'm eager to test out the range of these links. It "should" be the bomb! :)

  • I hate to suggest yet another terminal emulator, but puTTY is all I ever use on all platforms.
    And it is easy to adjust the end of line settings, though I don't think I've had to change the defaults for anything in the last 15 years.
  • Why dont you use MO 3dr radio config terminal ?

  • Jip, I've got that part thanks. The problem was with entering config mode on the modem with '+++'. Anyway, think Hyperterminal added new line characters, so switched over to Termite.

    I now get into config mode, but can't manage to retrieve or set any data on the modem with the AT commands. The modem just echos the command back to me... so it probably gets rejected?

    For instance I enter '+++' and get 'OK' as acknowledgement. After that I enter something like 'ATI5' or 'ATI', 'ATS8?' etc. but the command is just echoed back to me

    3702307704?profile=original

    I must admit, I haven't worked with AT commands a whole lot, but it seems straight forward... Am I missing something?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
2 hours ago
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Monday
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
More…