Setup of New RFD900 Radios

Can someone direct me to a website to setup and get working of Two RFD900 modems one on a Pixhawk, Tarot 680 frame ?  Or maybe Youtube.com

And the other on a Base Station with LONG rabbit ears.

Thanks for any help !!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Me too could not connect mission planner with pixhawk from Rctimer(fixhawk). Then I followed this video and connected teh air module in this manner. But it is getting power from the pixhawk board. I am not getting more than 100 meter range. Probably need to power it up with seperate 5V power. Still looking for solution. https://www.youtube.com/watch?v=mScWEMlZXL0

    James tate said:

    I'm using a 5v BEC to power the RFD900+, It can pull upwards to 1amp and that a little much to come off the Pixhawk. I have 2 RFD900+, One as Base Station and one on the Tarot 680Pro Hex.

    Each one is Powered with it's own 5v BEC

    To add another pointer,  I cannot get the latest MissionPlanner to connect with the 2 900+ modems , but I can get the Amplanner2 to connect without any problems.

    • Thank you for your responds. The website you gave me wasn't much help, I already have the Radio Base Station setup and RFD900+ setup on a Hexicopter and wired in.

      I'm using a RFD900+ I can connect to MissionPlanner at Com Port 6 57600 but I keep getting the error message;

      "Failed to load Command Mode"  

      and the LED on Base Station radio stays at Solid Red while USB cable is plugged into Laptop.

      I'm trying to interface with a Pixhawk, Firmware 3.3 RC8 .

      I get the same results while using 3drRadio.zip and RFDTools-V1.6.zip Applications.

      I even called 3dr Support and they can't help me.

      • So...maybe you should be more specific in your first post?

        Asking, "How do I drive my Chevy Malibu?" when you really need to ask, "why won't my Chevy Malibu start, and the check engine code is 1234."

        Good luck troubleshooting that, though. Perhaps a firmware mis-match between radios?

        • James,  Just curious but how are you powering the base RFD?  Are you using a separate power supply or the USB with the jumper installed?

          Regards,

          David R. Boulanger

          • I'm using a 5v BEC to power the RFD900+, It can pull upwards to 1amp and that a little much to come off the Pixhawk. I have 2 RFD900+, One as Base Station and one on the Tarot 680Pro Hex.

            Each one is Powered with it's own 5v BEC

            To add another pointer,  I cannot get the latest MissionPlanner to connect with the 2 900+ modems , but I can get the Amplanner2 to connect without any problems.

            • I have mine running off my APM 2.5 with no problems.  The base 900 uses a 5 volt bec.  I would think that the base 900 would blink green if it was just a firmware setting.  I have had a solid red light once or twice.  I think in my case, on the base 900,  it seems to be picky about if it was powered up and then plugged into the usb or vise versa.  Try plugging it into the GCS and then plugging in the 5V supply

              Regards,

              David R. Boulanger

              • I had the same problem with a solid red, which means that it is looking for a firmware install or upgrade.

                Use the RFDtools-1.6 app to install the Firmware

                I did a install on both modems to RFDesign 2.12 firmware and that solved the problem.

                A solid green or blinking green means it's communicating .

                On the common ground from Pixhawk to RFD900, I connected the black ground wire from Pixhawk to pin 1 on the plug that is connected to odd number of pins on 900, that is grd.

                The Pos. red wire from Pixhawk is not needed and I just taped it up.

                The +5v from the BEC goes, Black wire to pin 2 and Red wire goes to pin 4 on 900+.

                I just modified the Servo plug wires from the BEC to have Black and Red wires in plug and cut off any third wire and plugged it onto pin 2 an 4 on 900+.

                I hope this helps.

            • Admin

              @James,

              Did you establish a common ground (rtn) between the Pixhawk and the BEC power supply and the GCS and the BEC power supply?

              Regards,

              TCIII AVD

      • Admin

        @James,

        Who did you buy the RFD900 telemetry radios from?

        Regards,

        TCIII AVD

This reply was deleted.

Activity

DIY Robocars via Twitter
Sep 9
DIY Robocars via Twitter
RT @chr1sa: We've got another virtual @DIYRobocars race tomorrow at 9:00am PT. Two dozen autonomous cars will compete, four at a time. Ther…
Sep 4
DIY Robocars via Twitter
Sep 1
DIY Robocars via Twitter
Aug 31
DIY Robocars via Twitter
Aug 31
DIY Robocars via Twitter
RT @ExplorerRobocar: Sometimes, I am really a big kid!! Having fun with my virtual RC car on the @diyrobocars track 😜😉, by using the « AR R…
Aug 24
DIY Robocars via Twitter
RT @grepLeigh: @donkey_car @unity3d @TensorFlow ~1050 episodes into training, my agent learned to erratically drive in the left lane. 🤖😆 ht…
Aug 24
DIY Robocars via Twitter
RT @EclipseCyclone: Sweet! http://Robotec.ai high performance #ROS 2 @unity3d #CycloneDDS bridge for @AutowareFdn @SVLSimulator now…
Aug 24
DIY Robocars via Twitter
RT @a1k0n: My car had a lot of trouble getting around the track at the last @diyrobocars event -- only one actual finished lap during the r…
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map https://t.co/VzykOkUt2G
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: Made a lot progress on Warm Spring Raceways track. Almost finished one lap. https://t.co/nUVpufZQyP
Aug 24
DIY Robocars via Twitter
RT @AntonioRobotics: Super fun time seeing these autonomous cars race at @circuitlaunch for the @diyrobocars quarterly meet up! The demolit…
Aug 15
DIY Robocars via Twitter
RT @a1k0n: I thought my dumb localization code was still working at the new @circuitlaunch track, but it was just *barely* working. I shoul…
Aug 14
DIY Robocars via Twitter
RT @DAVGtech: Recording of entire in person @diyrobocars race today @circuitlaunch. Fast forward a couple hours to go straight to the racin…
Aug 14
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map. Very noisy Lidar signal https://t.co/bAbeVUMi10
Aug 14
DIY Robocars via Twitter
RT @SmallpixelCar: Today’s race with @a1k0n at @diyrobocars We both decided jumping over the wall was the way to break the 11s lap time. Th…
Aug 14
More…