Sonar PID setup

 

What a great project this has turned out to be. It has been really satisfying just getting to this stage and I haven't even flown more than a couple of meters in testing.

I have completed most of the fine turning of the Quadcopter and have wired in a LV Maxsonar EZ4.

When running the CLI serial setup, there is an option 'o' for setting up the sonar PID and some other roll and pitch pids which are all set to 0's by default.

I have searched the forums looking for Sonar setup guides but have not found anything relevant.

Has anyone had any experience with setting these parameters or can point me in the right direction?

Any help would be greatly appreciated.

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Developer

    Mine has just shipped so I plan to get it running this weekend. Really excited too!

    Jason

  • Is sonar work with BPM together ? Or just choose one ?
  • I have installed, but not yet tested the Sonar on my Arudcopter, so I don't have hard facts, but the Arducopter Wiki (on the Sonar page) says the following:
    • check the PID values through the CLI menu's "o" option. Good values if you are using standard ArduCopter hardware are P=0.8 I=0.3 D=0.7
  • these PIDs should have default values (not 0, if they are , initialize eeprom))

    use them as starting poiunt, if it doesn't work well, tune them (like any other PID)

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…