Stuck with Mini APM V3.1

I am as beginner as it gets.

I ordered this:

http://www.banggood.com/Mini-APM-V3_1-ArduPilot-Mega-External-Compass-APM-Flight-Controller-p-939771.html

The one I got looks like this:

3691286715?profile=original

I attempted to follow this for setup:

https://www.youtube.com/watch?v=Zv49LdcaLv0

I keep getting stuck after the firmware is uploaded and verified. I have tried the latest release of the mission planner software. It gets stuck right after the firmware is verified and I click connect. It can't connect. If I use the wizard, it gets to the point where the little box pops up and says "get params". It does not advance past that.

I get the same result with the two previous releases.

I also tried it with the release the gentleman is using in the youtube video (1.3.16). I get a little further with this one. If I follow the video exactly, not using the wizard, It does connect and gets to the point were it says "Got param RC1_MIN". It does not advance past this point

I have tried 4 different usb cables. I have tried every usb port on my computer. I have tried identical strategies more times than I can count. I have looked through some forums. I have not found a solution.

Does anyone know what I am doing wrong? Does anyone have ideas they would be willing to share?

Thank you

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • This is a video connecting to a NAZA which is basicly the same as Pixracer which uses SBUS.

    https://www.youtube.com/watch?v=NCXxlZp6TAA

  • To use the R9D with a Pixracer or Pixhawk you need to ditch the individual cables and just use one cable connected to 9.  They even have a video on how to do it.

    • Do you know where I can find that video?
  • So I got that pixracer in, we built up the quad. We were able to calibrate the sensors, but unable to get it to communicate with the transmitter and reciever. Not sure how to connect the R9D to the pixracer.

    I'm also running out of time on right now. If we cant get it working in the next couple days, I'll need to get something decent that handle a gopro so I can shoot video for the next two months and then come back and try to complete this build. Does anyone have a suggestion of a out of the box drone I could pic up so I can get ariel video with this gopro for the next couple months?

    https://drive.google.com/open?id=0B-1SJ-5JyqcwWlk0UHJkdDM1Um4zQnY1S...

    https://drive.google.com/open?id=0B-1SJ-5JyqcwUGt1a2ZlN240YnZIbUlwL...

    • The power adapters are ACSP4 which has the 6 outputs built on the board so you can use it as a distribution board.  The ACSP5 is just a power module with no distribution just straight through.  You have to provide your own battery connector and wire on both options.

      You could use your APM power module but you would need to make a cable from the power module to the Pixracer.  Or you could solder the power cables from APM power module to the ACSP5.

      Sadly the firmware for this unit is a little up in the air right now.  APM is in development stages and PX4 flight software is ok but you would need different software to work with it.

      APM3.3.4 pixracer firmware works ok and has most functions of this board working so you can start there and when the firmware catches up you will be in business.

  • If you have later than 3.1.5 arducopter installed, the terminal interface was removed. So it is normal to see giberish in the terminal screen.

    If you want to clean up memory corruptions install firmware 3.1.5, then connect to terminal, the type setup, erase, reset and then reboot the fc.

  • I had a friend over last night who understands this much better than I do. He used the terminal tab in MP to try some things. It was very corrupted at first, only returning complete gibberish. He did manage to flash it and get some more sensible feedback, but we were unable to properly program it. It was still returning gibberish in the end. He also came to the conclusion that something must be wrong with it. I have contacted banggood. They have forwarded all the info to the manufacturer and I guess we're waiting from a reply from them. I am going to take you up on your suggestion, Michael Burmeister, and look at the PixRacer with serious consideration. Thank you everyone who has replied here. I'll keep this up to date.

  • I use just about any USB cable and they all work just fine.  You have some other issue.  Before you flash the unit with Mission Planner, if you pull the port settings box down does it identify the board you are connected to or just say serial device.  It needs to say what board is connected.

    • First, MP does not have to enumerate the type of com device for it to work. Two, clearly he is selecting the correct com port if he is flashing firmware.

This reply was deleted.

Activity

DIY Drones via Twitter
RT @seesharp: I'm tuned into the PX4 / Dronecode free live conference. Great stuff. Microsoft AirSim talk in 10 minutes. https://t.co/0zbZ2…
19 hours ago
DIY Robocars via Twitter
RT @masato_ka: 距離センサを3つとESP32を付けたラジコンカーをDonkeyCarライクにNNで自動走行。3層FC極小モデルをTensorFlow Lite for microcontrollerで動かしてる。機体は借り物でRumiCarって言います。Tenso…
yesterday
DIY Robocars via Twitter
RT @SmallpixelCar: My car was able to go all the way autonomously until the crosswalk. It was only 100 yards from the target. What should b…
Saturday
Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
DIY Robocars via Twitter
RT @SmallpixelCar: Smart move. The car used the shadow to guide it through the bridge. This was never in the training samples. But it learn…
Jun 30
DIY Robocars via Twitter
RT @SmallpixelCar: Getting closer to the target. Single camera. Untrained road. https://t.co/Wsr7RwDamj
Jun 29
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
DIY Robocars via Twitter
RT @RoboticMasters: #donkeycar https://t.co/czuLoVRcA4
Jun 29
DIY Robocars via Twitter
https://t.co/DKQbNTbz0g
Jun 29
DIY Robocars via Twitter
RT @RoboticMasters: Donkey car, car car car car car car; Donkey car, car car car car car car; Donkey Car. Anyone like our tiny tiny donkey…
Jun 29
DIY Robocars via Twitter
RT @SmallpixelCar: After improving DBSCAN speed, I can get 11 frame per second on @NVIDIAEmbedded Jerson Xavier MAXN mode and the autonomou…
Jun 26
DIY Robocars via Twitter
RT @Heavy02011: Join us at next Virtual Race League: ⁦@diyrobocars⁩ Race #4 - Parking Lot Nerds, August 1st https://t.co/5KUpu7VGaH
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: #CUDA implementation should be easy, because most of the time is on distance calculations berween two points and if the…
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: This is the view from the car. Even my lanenet inference is fast on @NVIDIAEmbedded Jerson Xavier, DBSCAN clustering tak…
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: Ran my car in the park, with single camera and @sparkfun IMU. #TensorRT on @NVIDIAEmbedded Jetson Xavier. Lanenet one fr…
Jun 24
More…