Sudden takeoff in Althold and Loiter mode

Hello fellow pilots,

A couple days ago I was flying my quadcopter running on apm 2.6, wich was working fine.

Stab, Althold, Loiter and Auto mode worked flawlessly.

Until yesterday, when I switched my flightmode to Althold or Loiter, my copter accelerated to the sky.

Quickly I switched back to stabilize to get control. 

From my experience with apm I immediately thought it would be a badly covered barometer.

I removed the cotton ball, wich was covering the barometer and replaced it with some foam (same foam as inside pelican cases).

After that I took my lovely quad outside to test Althold and Loiter, still the same :(

During the flying in althold and loiter my throttle was at ~50%, my osd and telemetry doesn't show inaccurate altitude readings.

Also my Pilot maximum vertical speed always changes itself to this value, I can't change it neither via telemetry connection nor with usb connection. Could this be the source of evil in this case?


So i'm lost, I don't know what other things I could check.

I have attached my tlog of this evening where you can see the sudden gain in altitude like at 21:14:46.

I would be incredibly thankful with any help.


2014-08-10 21-13-38.tlog

2014-08-10 21-13-38.rlog

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I'm sure it has something to do with throttle setting in loitermode,

    • Thank you Kim,


      I tried changing the value to 500cm/s in standard parameters, but it would always change back to the faulty 327637cm/s.

      Only when I changed it in full parameters list it did finally keep the value of 500cm/s



      • Hi Robert

        did it solve your problem ?

        • Hi Kim,


          My copter is now flying as it did before, loiter and althold works great.

          My throttle setting now keeps the value of 500 cm/s.




          Thank you very much

  • I am having the same issues with my quad at the moment. I have done some reading and found the manual of Arducopter stating that take off in Alt hold and Loiter mode suggests that the vibrations on the APM is to hectic. I did what they suggested and found that for some reason my Z-Axis vibration is outside the suggested targets. 

    If I fly a 4S lipo, the take off is much better but still there, however, when I put it in Loitre mode ... the copter drifts off to the right. I also have not had any time to look at this but any suggestions will be welcome. 


    • Johann, thank you very much for your reply.


      I will try rearrange my wiring around the apm to minimize the vibrations and look at my logs for x/y/z vibrations in a coule of hours.

      Will post the results and my findings ASAP.


      Again, thank you


      PS: looking at your name I assume you're dutch too, wich area are you from (just curious). I'm from Den Bosch FYI.



      • My copter is fully functional now, there were too many wires translating vibrations to my apm via the connections. I loosend up the wires so my apm could move completely free.

        Johann considering your problem with the drifting to the right, I suggest you make sure your apm can move freely. Use vibration foam underneath if you haven't already.

        Also recalibrating your accelerometer, run autotrim, use save trim and run the autotune proces may solve your problem.


This reply was deleted.


DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
21 hours ago
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training
Nov 28
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord:
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch
Oct 23