Telemetry Not communicating with APM

basic problem i am having is that my Telemetry setup wont communicate with my APM.

hardware:

Software:

  • Mission Planner 1.2.67 
  • init ArduCopter V2.9.1b

My first problem was that the Xbee would not even communicate with themselves before ever connecting to the APM. Turns out that if you have the "Xbee explorer adapter" from sparkfun you have to edit your Xbee firmware to correct pullup resister parameters  (this is a whole other issue). Once i fixed that i was able to have my Xbees range tested and all worked out correct. I connected my APM to the PC via usb and made sure that my firmware and updates are ok and all went fine.  The problem is that when i connect my Xbees to the APM @ 57K at the correct port (USB is not connected so not to conflict with telemetry) it wont connect. My Adapter board on the PC side has LEDs (TX/RX) that don't light up indicating to me that there is nothing coming from the mission planner software to even try and connect. Have I missed something that needs to be configured on the Mission planner side that i have not realized? I am at a complete loss.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Did someone resolve this? Any inputs are appreciated as I am facing the same problem but with Pixhawk and XBee Pro S1 not communication. The two Xbee modules communicate directly with each other when connected via PC.

  • I was having similar issues until I realised my APM was doing funny things to my airside Xbee by sending it data before it was ready. I don't think it was bricked, as I could still plug it in and connect to it using XCTU, but it certainly wasn't working properly.

    I restored it using the steps here and then set the telemetry startup delay parameter (TELEM_DELAY) to 10. This forces the APM to wait 10 seconds after boot up before it starts spitting data out to the Xbee. Seems to work now.

This reply was deleted.

Activity

DIY Robocars via Twitter
11 hours ago
DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
Wednesday
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…