[Solved] Twitching apm 2.5

I have an apm 2.5 I have trying to tune.  I have it tuned out so that it responds accordingly but I have this odd twitch.  It will twitch to the right on the yaw and it will twitch backwards on the tilt axis.  I'm not sure whats causing it.  I've played with PID quite a bit but haven't found anything helpful. 

Has anyone else seen this?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Well kids after doing some testing I have the answer to my problems!  Props go to Ted for this one as he pointed me in the right direction.  Updating the PPM Encoder fixed the issue.

    Thanks for the help folks!

    • Well rat, I'm using PWM

  • currently having the same issue.

    do you have log files with att and raw eneabled? you can see that commands are fed to the copter (roll, pitch, yaw, throttle) and mine has some spikes on it (see attached).

    ...i could be some interference from the huge noise the esc and motors puts out.

    this appears to be the most developed thread I have found:

    http://diydrones.com/forum/topics/motors-twitching-in-flight

    one person fixed it by using a different receiver. another fixed it by flashing the ppm encoder on the APM2.5 board to the latest firmware. But it doesnt exactly reach a final verdict, or it isnt very clear at least. I am also having some issues with my APM giving out garbage numbers in the log download section. 

    my thread is here:

    http://diydrones.com/forum/topics/what-is-happening-to-my-apm

    good luck!

  • A little more useful info.

    I have flown it for awhile on a kk2.0 with no twitching.

    Currently I have it on the 2.9.1 firmware

    SimonK flashed Plush 25 amp ESCs

    I have tried 2 different sets of motors both with the same issue

    GPS is unplugged

    Turnigy Talon Frame

This reply was deleted.

Activity

Santiago Perez liked Santiago Perez's profile
Saturday
More…