As in the object, my quad with a pixhawk running arducopter 3.4.3 stable, can't execute "ROI" or the "Point camera here".

The quad perform Loiter, alt-hold and auto mission very very well, and even guided and circle mode works with no problem at all..

In auto mission I have inserted a ROI in a simple mission and the quad completely ignore it: when it arrive at the ROI, it dosen't yaw (i have a tarot t2d 2 axis gimbal) to point in the ROI direction and the gimbal don't point down at the desired ROI altitude.

I have tested the "point camera here" too: the quad doesn't yaw in the desired direction, and the camera rotate 90 degrees up and it remains blocked in that position unitl i land and disconnect the battery.. Mission planner give an error at this point: "The Command failed to execute".


Below a link to my google drive folder with some ***.bin files of my test, the mission.txt file of the auto mission, the full parameter list of my pixhawk (parameter.param) and the screen shot of the mission planner's error.
https://drive.google.com/open?id=0B6YUJhp7SURxNGJ2dmVQMm9ONWc

Views: 164

Reply to This

Replies to This Discussion

The problem is solved!!

I'd like to share with the comunity the solution: it was a my error with the configuration parameters.

My gimbal configuration was like the procedure described in the wiki, so i have used my radio channel 6 ti control the gimbal tilt connected to the aux1 (rc9) on the pixhawk.

And then, i have used my radio channel 8 to control the gimbal operation mode with another wire connected on the aux2 (rc10) of the pixhawk, but my error was to configure this part, in the gimbal setup page of the mission planner, in the "pan" section.

From the radio the gimbal work as expected, but in auto mode, the drone won't yaw itself in the ROI direction.

The solution was to configure properly the gimbal operation mode like described in the mike_kelly guide, all credits goes to him.

So i have moved the wire connected to the tarot "operation mode switch", from aux2 (rc10) of the pixhawk, to the motor output8 and then i have configured the rc8 like below:

RC8_DZ,0
RC8_FUNCTION,1 --> passthrough of rc8 of my radio
RC8_MAX,1900
RC8_MIN,1100
RC8_REV,-1 --> inverted
RC8_TRIM,1504

With this configuration my quad execute correctly all the ROI waypoints in auto mission, as well as commands like "point camera here" from tower and after a little bit of adjustment of the pwm values on my taranis, even the control of the gimbal from the radio is perfect.

Ok, I have finally made some progress in setting up my Feiyutech gimbal where,  'Point camera here' and ROI seems to function as intended however,  it would be nice to have the subject (of the ROI) a bit lower in the shot/frame.

Does this mean I could adjust the PWM values  up  or down within mission planner?

Or just adjust them on the Taranis?

(I'm a little exhausted of trial and error with no result.)

Note: I'm running the same auto mission over so as to see the change but.... no change

Reply to Discussion

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service