unexpected engines shutdown APM 2.6 + Arducopter 3.1.2

Hello,

My copter was crashed yesterday because of all engines were stopped without any reason. According to the log files the apm receives invalid altitude value from GPS and it looks like it can be an explanation for my accident, but I'm not sure it's a good reason to switch all engines off and fall to the ground. I'll explain everything step by step:

1. I armed my copter and take off in stabilize mode

2. Made several loops in Loiter mode and switch it to RTL mode

3. After arriving I switch it to Alt hold mode

4. After I switched it to stabilize mode and tried increase altitude

5. After reaching ~100 meters all engines were stopped at the same time and it began to fall

6. after about 1.5 or 2 seconds of my attempts to do something all engines were started again

7. I tried to restore its orientation, but it was impossible and it fell on its back

Any Idea what could be a reason of such behavior (last log is attached)?

Thank you! 

logs.zip

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • same thing happened to me.. after a crash and a rebuild.  Been scratching my head for a week and a half on this.. it arms, at 45-50% (the quads' lift off throttle) it lifts off for a couple of inches and then all the motors shut down at the same time.  It happens everytime.  FINALLY, a few minutes ago, I decided to calibrate the compass and accelerometer.  Son of a gun.. it worked! 

    Moral lesson.. after each crash, calibrate!

  • Had exactly the same with one of the 3.1.2rc's. Luckily this was only hovering 1-2 feet on soft grass, so only one cracked prop. Suspecting the firmware I went back to what was on before (3.1rc7). I hovered very close to the ground and found the APM randomly rebooting. This is I guess what you saw with the APM coming back to live after 1.5-2 seconds. After I disconnected my gimbal (on the same 3s battery) the problem went away. So my conclusion was a bad intermittent power connection to the gimbal that caused the power module/APM to reset. I replaced the power connector to the gimbal hoping this was the root cause.  Since then I flew 4 batteries without any issues. Your post makes me nervous.

    • Thank you for your reply! You know, I also suspecting my 6-pos connector between 3DR Power Module and APM board, but I'm not sure. Now I replace it with a new one and also flew about 6 batteries without any accidents...

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
yesterday
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
yesterday
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
yesterday
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Sep 26
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
More…