Windows 10 and Pixhawk problems

Hello.

I´d say I now have read all threads concerning win10 problems but not one seems like mine.

I´ve recently updated to win10 and have the following problem.

I can connect to my pixhawk via 3DR Radio on mavlink. This is good to get telemetry and parameters on an from the Pixhawk.

My problem is that i can`t get any connection if i directly connect to pixhawk via USB. My Mission planner neighter recognizes nor shows my Pixhawk in the connection tab. Usually it showed up as an additional com port under win7 but nothing happens now.

Here are some facts:

drivers installed, several times, also different versions -> so no prob with that

device manager recognizes Pixhawk and shows it

baud rate set to 11500 in device manager and also in mission planner

drivers are up to date

mission planner updated, also tried different earlier builds (complete uninstalled and reinstalled)

While trying to connect it says connection failed after one second

It´s pretty good to get a connection via the radio so i can fly and change settings, but i can`t download log files as it says "get log" timeout. Therefore I wanted to connect via USB but it doesn`t work.

I can connect to a friends Win7 laptop but thats no solution for the future.

Does someone have the right recommendation how to fix this problem.

Thanks

Ben

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Can you please upload this file somewhere since the specified page no longer exists!

    djtrickee said:

    I had to reinstall the drivers. I used this link and am now able to connect via both USB and wirelessly whereas earlier I was only able to connect wirelessly.

    http://pixhawk.org/static/px4driver.msi

    Windows 10 and Pixhawk problems
    Hello. I´d say I now have read all threads concerning win10 problems but not one seems like mine. I´ve recently updated to win10 and have the follo…
  • How do you do it? I have not seen any virtual port... PX4 PMU com4

    Thanks in advance

    • I had to reinstall the drivers. I used this link and am now able to connect via both USB and wirelessly whereas earlier I was only able to connect wirelessly.

      http://pixhawk.org/static/px4driver.msi

  • Hi Ben.

    I posted this on the APM forum recently, which sounds as if there is some similarity...I cant help wondering whether it's a Windows problem generally with the Pixhawk.....In my case Windows XP on the laptop and Windows 7 on the desktop.

    Hi all.....
    I've been having a real time of it. (Pixhawk and 3.2.1FW)

    Having just returned from holiday and taken out my quad for a spin (previously working perfectly), I was rather irritated to find that I could not connect via the 3DR radio with my Android device, nor could I arm the Pixhawk, as there was no satelite fix (open playing field) and the OSD was receiving no telemetry at all.

    Having returned home in disgust, I tried without success to connect with MP.
    So I decided to reinstall the copter firmware having overwritten with plane 3.3.1.

    With firmware loaded, I then tried to connect and got failure after failure, mainly due to 'Access denied to 
    Com1 port'. Despite the serial port showing in the device manager, and working.

    So I tried clearing the port register using regedit, with little luck, and then tried connecting with APM planner, eventually succeeding, only by going the "wizard' route.....

    This has all proved to be very tedious indeed, and I wonder why it should suddenly be so difficult to connect to the Pixhawk..... Even on my laptop.
    Has anybody else suffered the same frustration?

    Any wisdom would be most welcome!. Best DP
    Subsequent to this post I dug out my APM 2.6 to see whether there was a connection problem with that FC, but it connected first attempt......
    Let's hope that someone can throw some light on this!
    Best DP.
  • MR60

    A shot in the dark but this happened to me in win 7, and incredibly it was solved after a reset and reinstallation of the Pixhawk firmware. 

  • I updated to Win 10 but without any issues.  If the com port is showing up in the device manager but not in Mission Planner try uninstalling/reinstalling MP or perhaps try updating to the beta version via the help page.

    If Windows can see the com port but you can't connect to me it sounds more like something broke in the Mission planner/Windows side of things.

    I can tell you that it does work so don't give up!!

    Good luck!! and let us know how you go.

  • Hello

    When I read:

    "Usually it showed up as an additional com port under win7 but nothing happens now."

    Sounds like you just have the first part of the installation completed (FTDI DRIVER).

    Under Win10  you have to return on the device manager to complete the FTDI mapping of driver to a COM (VirtualCom) port.  It might not be the case but you can give it a try... :-)

  • Developer

    does the pixhawk show up in device manager when you connect it.

    also can you test on another pc to check usb is working correctly.

  • you might find something here

    http://diydrones.com/forum/topics/mission-planner-for-windows-10?co...

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: @DanielChiaJH @diyrobocars @circuitlaunch Here's my car's view of that race. About 8.4 second lap times for laps 2 and 3... both…
yesterday
DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
Sunday
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
Saturday
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
Saturday
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Sep 26
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
More…