I am using the following telemetry kit.

http://store.diydrones.com/Xbee_Telemetry_kit_p/kt-telemetry-xbee.htm

 

I have the right ftdi drivers installed on my laptop. For some strange reason, when i plug the usb adapter into my laptop(running windows 7), around 50% of the time, it recognizes it as a serial mouse.

Very aggravating, because i lose control of my laptop, the mouse pointer gets a life of it's own and finally everything hangs.

I need to restart over and over again, till it decides to work. Has anyone else experienced this? Are there any workarounds?

 

Srinath

 

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I confirm Andreas' solution is working... i've been looking a bit in order to find out really whats going on. The only thing i've got so far is that it's not APM or XBee related, it's recurring though almost all windows versions (from XP to 7), and it happens when you connect any serial device already receiving data just like our case here with Xbee...

    Now the real question is WTF was going though their heads to keep including in latest Win 7 x64 versions, drivers of a 20 years old mouse messing up with current devices used on a daily basis ?

    This is the mouse, every one still use one of these right ? It rocks with Windows 7 Ultimate !

    3692352359?profile=original

    Maybe this thread offers a solution : http://forums.techarena.in/xp-hardware/716002.htm

    I haven't really tried anything yet i'm away and i don't have the PC around.

    Microsoft Serial Ball point mouse not detected in Windows XP - XP Hardware
    Microsoft Serial Ball point mouse not detected in Windows XP, XP Hardware, PCI cards, storage, motherboards, processors, RAM, peripherals, and more..
  • It used to happen 20% of the time for me. Unfortunately on the flying filed last Saturday it happened 100% of the time and I could not fly with the Xbee link. Also I can't do anything in the device manager as soon as the Xbee is plugged in. Any links to a working solution?

  • Paul, you mean that when you plug the ground xbee module to the USB, the plane module is already transmitting data ? When i do that either it jumps the mouse crazy or it bricks the Xbee...

  • Mine running on Win 7 64bit and worked from the off, no problems.

    TX on quad power on start mission planner then lastly connect the USB to the Xbee, select the com port and speed then connect, so far works ever time.

  • The only thing i've found is that when plugged to the computer, the port should not be receiving data... if i plug first the computer module and then i turn on the plane module, it works...

  • Same problem here... i'm gonna try Simon's workaround... those Xbee are driving me crazy...

  • I have the same problem. I didn't find a solution to it but the following reliefs the pain a bit:

    1) open the windows device manager

    2) open the "Mice and other pointing devices" tree node

    3) Plug in the xbee module

    4) A second later, the new mouse driver becomes visible. Right click it and chose "uninstall"

    You have to be very fast in step 4, i.e. you have to delete the driver before the mouse goes mad.

    If someone finds a real solution to this: please share...

    Cheers,

    Simon

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Saturday
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
More…