XBEE won't work with ESC.

Weird problem again.

XBee works fine both receiving and transmitting with power from     USB-> APM -> XBEE and

5V Battery-> Receiver -> APM-> XBEE

 

 

But when using with ESC or BEC it only works transmitting data from APM to my PC.

But not the other way around. When i send something from my PC to APM the ASC/RSSI on XtreamBee board light up.

 

I'm using XBEE PRO 2.4.

I'm setting Baudrate in the ArducopterNX to 111111 and PC to 115200 with 2 stopbits.

 

Any suggestions would be greatly appreciate.

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • i discovered that i have this problem too..

     

    Battery to ESC to APM to Xbee doesnt have enough power for the Wireless link communication.

     

    Whereas i plug USB to APM to Xbee the Wireless link is successful.

     

    Can guide me how to solve this under power problem?

  • Thanks for posting the Eagle files.  It's been a while since I've done any hardware design.  I can see how the DI input going to the xBee gets switched between DIDO and DODI signals coming from JP2, but I don't understand how the DO output from the xBee gets switched.  It may be a silly question, but can someone explain how this works?  I don't see anyway that DO from the xBee can be used as an output on JP2.
  • FWIW, the xBee Pro 60 milliwatt radios seem to have voltage level issue when used with the XtremeBee adaptors.  I got mine to work after putting a 7.5K resistor in the tx and rx lines between the xBee adaptor and Oil Pan shield.  I'm also going to try the diode/pull up as detailed on the Sparkfun site when I get my hands on some diodes.

    JI

  • I have two Xbee Pro Series 2 2.4

     

    Which function set i have to set ? [ ZNET 2.5 ROUTER/END DEVICE AT ? 1247 ]

    One connect IMU with sparkfun adapter and one connected the computer with sparkfun USB explorer.

     

  • Be interested in what you find.  In the mean time, can I get a copy of the adaptor board schematic to see if I can work out a level shifting circuit to make what I have on hand work?
  • I've got the same problem, and know of another user who has it too.  Two 60mW xBee Pro's on XtremeBee adaptors.  Baud ratea set at 57600, master mode selected on adaptor boards.  Hooked up to FTDI's and 2 laptops and they communicate just fine.  When one is hooked up to Serial3 on the APM stack, it will transmit data to the laptop, but it will not receive it from the laptop.

     

    The xBee on the APM knows it's getting a transmission as the red RSSI LED lights up on it when you type on the laptop, but there is no sign of activity on the DO line, the amber LED never flashes.  Same behavior is exhibited if I swap radio positions between the APM and laptop.

     

    Also it does not matter if I power the APM stack from the USB cable or from a 3S 2170 lipo connected to the power input pins, same behavior.

     

    Is there a schematic of the XtremeBee board availble so we can look at what we are dealing with?  I'm going to try reversing DO/DI at the APM end and setting slave mode and see what happens.

     

    John

  • I try connecting diode between ESC/BEC and APM to drop the voltage down from 5.15V to 4.85V and Xbee works!

    But is this normally happening to other people?

    Will there be any consequences to other system on the board?

  • Is it the same problem as this guy?

    http://www.diydrones.com/forum/topics/xtreambee-board-at-5v

    with USB or Battery the voltage level was about 4.8V

    with ESC it's about 5.1V

  • Moderator
    Not enough power
This reply was deleted.

Activity

DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
RT @Heavy02011: @diyrobocars : A Home-brew computer club* for Connected Autonomous Driving on Jan 23rd, 2021 https://www.meetup.com/Connected-Autonomous-Driving/events/275728684/ #Meetu…
Thursday
DIY Robocars via Twitter
Thursday
David Hori liked Isabella Domi's profile
Wednesday
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ Autonomous Driving Assembly at #rC3. join us at https://rc3.world/rc3/assembly/diyrobocars-f1tenth/ ⁦@f1tenth⁩ ⁦@DAVGtech⁩ ⁦@DWalmroth⁩…
Monday
DIY Robocars via Twitter
RT @chr1sa: New car designs coming for our next @DIYRobocars @donkey_car virtual race on the 23rd. Choose any one you want at race time Le…
Monday
DIY Robocars via Twitter
RT @RoboticMasters: Thanks to @EllerbachMaxime and the Sydney Uni Capstone Students the @donkey_car @diyrobocars simulator is getting a ma…
Monday
DIY Robocars via Twitter
Jan 6
DIY Robocars via Twitter
Dec 28, 2020
DIY Robocars via Twitter
An interesting line-following simulator to use with with your robocars: https://github.com/ron-grant/LFS
Dec 23, 2020
DIY Robocars via Twitter
Dec 23, 2020
DIY Robocars via Twitter
An improved version of the @IntelAIResearch OpenBot: https://diyrobocars.com/2020/12/14/an-improved-version-of-the-intel-openbot/
Dec 14, 2020
DIY Robocars via Twitter
Dec 10, 2020
DIY Robocars via Twitter
RT @KN_Richardson: Delivery 📦😬 Early xmas present from @ccbdcdt ! Sims ready, will put h/w together over Christmas break. Didn’t need to mo…
Dec 7, 2020
DIY Robocars via Twitter
RT @RoboticMasters: Did we mention there's new car models in the #donkeycar simulator too? Here is an RB16 from team @redbull @donkey_ca…
Dec 7, 2020
More…