Discussion group for ArduPlane users

1475 Members
Join Us!

You need to be a member of diydrones to add comments!

Join diydrones

Comments are closed.

Comments

  • @ Jason

    that's reassuring. I indeed suspected that inaccuracies in the simulation model would have the most part .

  • Developer

    HI Lorenz,

    Jason's comments are (generally) correct.  With a non-linear system sometimes you get counter-intuitive and unusual results, hence the small disclaimer.  Regardless, adding delay into a feedback path almost always reduces stability margins and requires lower gains, and removing the delay will increase stability margins.

    To really choose appropriate gains through simulation is a very significant task, requiring really good models.  I just did some test flights for a new UAV autopilot startup called BlackSwift last week - they (two aerospace engineering PhD's) had gone to considerable effort to find some starting gains prior to actual flight. Other than being stable, they were not very good at all, and about an hour of actual flight time was required for tuning...  Unless you have a really good physics model and really good airframe model I think that is about all you can get through simulation - conservative gains that at least you can expect to be stable.

  • @Lorenz - I think there are bigger issues with using HIL simulation for gain tuning such as imperfections in the physics / aerodynamics models employed by X-plane and imperfections in the model of your airplane in X-plane.  They are probably good enough for a starting point, but I think the only way to get good polished gains is from real flight.

    To answer your question though, delays have a destabilizing effect, so if I had to guess, I would say any gains that work with the delays in place would work better (and be a little conservative) when those delays are removed.


  • I don't know if this is the correct place to ask a aquestion regarding HIL simulation.

    I was trying to understand the effects of delays on the tuning of PID parameters.

    Has anybody been able to measure the delay between movements / disturbances of the aircraft in X-Plane and the availability of relevant data (attitude, sensors, ...) to the ArduPilot code ?

    This includes X-Plane sending data to ArduPilotMegaPlanner, that elaborates them and sends to ArduPilotMega board via serial communication.

    Since those delays are simply not there in the real flight situation, I suspect that the PID parameters resulting from HIL simulation tuning will be different from the ones for the real situation.

    Sincerely, I'd be happy if anybody could confute this.

    Regards

  • OK. Tried that already since I always clear logs after each flight. But problem seems to go away when I downgrade to 2.50. Then all logs get in the right order and can be downloaded. Hmmm..

  • 3D Robotics

    Jesper: No, datalogging is a different chip. To reset/erase that, do a logs/erase

  • Would CLI setup/erase/reset also reset the datalogging memory? I have wierd logging now with logs have higher start numbers than stop.

  • 3D Robotics

    velentin: probably some got corrupted in the EEPROM. Do a CLI setup/erase /reset and go through the config process again and you should be fine. 

  • hi there, I'm having problem with APM2, the response of the sensor is extremely low this is the second time that happens, I solved it re installing the codes I would like to find out what is causing this

  • @Tomas:  The best way is to directly look at the code, attitude.pde and navigation.pde.  It is commented pretty well.  From the wiki just click on the source tab and browse...

     

This reply was deleted.

Cruise speed

Hi,I want to adjust cruise speed.At default settings I have a ground speed of about 42km/h (without airspeed sensor), and I think the optimal speed should be lower. In the mission planner I have value "Cruise speed", default 12m/s. I updated it to 9.5, but don't see any change in actual cruise speed.How to set cruise speed?Are these different settings with RTL speed? For RTL I prefer keep it as is - less efficient, but more reliable.Is it possible to adjust cruise speed during flight, providing…

Read more…
0 Replies

Long distance LiPo

I'm currently building a Talon (v3), mainly waiting for parts.While looking for high capacity batteries I found out two things; There are a lot of brands, and prices are still steep in the high-cap regions.I've also seen a few people on the Tube using 18650 cells, but none of those explain why.Does anyone here have experience with these custom 18650 packs?And which 'cheap' brands of standard 5~12A 4S seem to work best?I'm going to use an Emax GT3526 710KV swinging a 13x6.5 prop, which should…

Read more…
5 Replies

Quad plane pitch problem

Hi I have been setting up 2 quad planes, pretty standard setups...flying wing with 4 vtol motors and a rear mounted pusher motor. Both builds wich are on different firmware versions have reversed pitch in quad mode but correct pitch and pitch stabilisation in plane mode. I cannot for the life of me find a parameter related solely to quad pitch reversal. Is there anyone out there that can help with this? Thanks.

Read more…
2 Replies

PreArm Check Error : Gyros inconsistent

Hi guys, I have a Pixhawk from Radiolink and always in every first attempt of armed I get the error "PreArm: Gyro Inconsistent".The most strange thing is that i'm using only the external gyro+compass. i disabled the internal to avoid this issue. Also- I tried to recalibrate the gyros at least 5 times.- I changed the firmware version from the latest to the 3.8.53 because i have a friend with the same board and he does not have issues.But i have the same behaviorIf i disconnect the battery and…

Read more…
2 Replies