Dear all, 

After an earlier post (12/OCT/2015) related to Pixhawk, I present you now the results of a first trial with ArduBoat. First, we constructed a simple platform and did some trials with RC in a swimming pool. 


This week we did some tests in a lake near Asuncion, Paraguay. The catamaran performed well in Manual Mode (has good steering and has enough propulsion to move in windy conditions).



The problem is when we put it in Automatic Mode. It seems that the waypoints are not read by the Pixhawk and when in Auto Mode is directed to the same place (is likely to be directed to a waypoint other than the loaded, however, in the LOGS, we didn't find any Waypoint, and less the ones introduced by ourselves).

When reading out the logs, it seems that our planned waypoints were not taken into account by the Pixhawk. We would be very grateful if anyone of you could help us decipher why it behaves this way. For this reason I attached my Logs.

Here are some images from the Mission Planer with the Waypoints loaded and the Path that took the Boat.


The Red Points were the Launching Points.

For the first trials we launched the platform from the A point and it didn't went to the waypoints, but, instead, went to B point. In a second attempt, we launched it from the B point and it went to the C point. So we decided to launch the platform from another location D to see to which direction it would navigate. In this launch, the platform went on a straight line to location E. Then we decided to do a second launch from the F point, initially directing the platform to different direction than E point, but surprisingly it turned itself in order to head again towards location E. It seemed to us like the platform was heading to an ´imaginary´ point somewhere far away!

Apparently the Pixhawk has only recorded the GPS points when he was Armed. Is that how it works? I should only load the Waypoints when he's Armed?

All recommendations will be very welcome.

Thanks in advance.

Best regards.

Esteban Caligaris




You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi Gilles!

    Yes! I'm attaching the Pixhawk this way:

    The Battery I'm using connects to the Power Module (PM) and the PM goes to the Power Port available at the Pixhawk.

    The ESC I'm using it's wired to the PM and to the Main Out #3.

    The Motor I'm using goes to the ESC (it doesn't matter what cable it's connected to the ESC's cables, but you have to switch a pair of cables in order to make your motor spin in one way or the other)

    The Servo I'm using connects directly to the Main Out #1.

    The GPS Module connects one cable to the GPS Port and the other one to the I2C Port.

    And the PPM Encoder it's attached at the RC IN Port and at the Radio Control Receiver.


    Esteban Caligaris

  • Hello,
    Can you show wiring diagram (servo, battery
    Thank you

  • s

    Can you show wiring diagram (Power, battery
    Thank you

  • 5) If the servo moves the Fan to a position that will not point the bow to the selected waypoint, that is where your problem is and must be corrected.

    hallo esteban i have the problem with the servo too, how could you solved this?

    Regards, Seno

    • Hi there seno nugroho.

      The problems I had were due to electromagnetic fields that were emanated from all the electronics that surrounded mi GPS Module, as I had all of the components stored in only one plastic container. My problems were solved by splitting the arrangement of the electronics in three plastic containers and by moving far away the servo from the GPS Module.

      Although, you should first see where's the middle point of your servo's head, as that point is where will point when the direction it's trying to reach is straight at forward.

      Also, you should see before doing any new arrangement if your servo should be working against the movement of the boat. For example, if your boat has to turn clockwise and your servo has to turn counter clockwise to achieve this, then you should change the RC1_REV param to -1.


      Esteban Caligaris

    • hello esteban, can you give me the parameter that you changes on ardu rover ???

      cause i had follow the intruction on the wiki but it didnt  work 

  • Thank you very much everyone for your contributions.

    I have solved my problem.
    The problem I had was due to electromagnetic interference, caused by having all components crammed into the same container.

    Initial distribution of electronics (All in one container):


    Results obtained (not as satisfactory as expected):

    3702175509?profile=originalLast distribution of electronics (In separate containers + GPS Mast):


    Results obtained (Very satisfactory):


    So now we're expecting a New Challenge, introducing others Sensors!


    Thanks for your time everybody.


    Esteban Caligaris


      Dear Esteban,

      you have built model airboat, so steering should resemble one in professional airboat.

      Just enter "airboat steering" into your search engine and switch to images to the idea of airboat steering system.

      Steering is accomplished by forced air passing across vertical rudders. There must be a forceful airflow in order for the vessel to be steered. Airboats do not have brakes and are incapable of traveling in reverse, unless they have a reversible propeller. "

    • Hi there Darius.

      The Steering, in everything moving with the impulse caused by a fan, is achieved by redirecting the the direction of the impulse, in this case, the air. That can be done with rudders or with the redirection of the thrusters.

      Anyway, thanks for your time in that research. I'll have it in mind.


      Esteban Caligaris

  • Developer

    Hi Esteban.  I had a quick look at your 199.BIN file.  Below is the mission that was loaded in the pixhawk and what it looked like on the map.  I'm not sure that's what you were expecting?  Remember whenever you create the mission in MissionPlanner you must remember to send it to the pixhawk.



This reply was deleted.