Setup trouble - motors only runs in shorts burst

Hi all,

TCIII asked me to post this here, so more brains could tell me where I'm being newbee or stupid. Just don't RTM me please, as there is a lot of stuff to cover for a new head here, and alot of doesn't count for a boat or rover. :)

Okey, back in april i started build a boat, which should be used together with my  spare chartplotter/fishfinder (Lowerance Elite 4 HDI) a few photos of that can be found here:

I have goten a bit longer, and the boat have been on a few trips on the water, but there are something wrong with it. 

Today, I tried to  make it run again, sometimes it runs one engine, then the other, only for a few seconds. Seems like an initiation of some sort. Other times it runs one engine for a long time, and the other just now and then.

My parameters: carlparam.txt 

And my log from MP messages: carlmessage.txt


This is brain part, it's mounted like this so I can take it with me.


Overview: The part at the bottom of the pictures is the real middle section and will be as good as waterproof for splashing etc.

The box on the middle section will contains the brain (picture above) and the fishfinder/chartplotter.
The hulls are made to be able to have 2x 12V 12Ah batteries installed each, if ever needed. (this setup seems to close to 20hours run time. (close to 1amp drawn for both engines and combo fishfinder/chartplotter)

electric.jpgElectrix madness part 1


electric madness part two :) 
(this is temporary as the plan is to solder all connections that don't need to be unplugged, but for the testing, it is great to be able to disconnect, and connect without needing to solder :)

If anything else is needed, scream for me (i.e.. reply to this post) or if you have the "newbee, do this" solution, to the same :)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • I tried to move the cable from rc receiver output channel 2 from apm input nr 3 to input nr 2, and apm output nr 3 to outpput nr 2 but after that I didn't have any output too right motor.

      Log files are ziped, and can be found here. All the log files was dated 01.01.1970, is there someplace I have forgotten to set time and date?

      I made a short movie, which can be found here. Really bad, I know, but it shows the propellers and my hand on the joystick....

      Below, a new layout of the "brain




  • I also noticed something today, which can be (part of) the trouble:

    Everytime i start running the motors, I get bad gps health and disarmed. As stated before, I'm quite new to this, but I guess the engines could make some noise on the electrical system, which then make to much interference for the gps/compass unit.



    • ok, new update, after looking into this problem, i connected the pc directly to the apm via usb, and it worked alot better. it's steady in reverse. and forward is a lot more "correct bursts" disconnected the pc, and the telemetry (and broke the cable connector too.. bah) on the water, red light and blue light went off when putting it in forward. 

      added another battery to the boat, which only feed the apm, and we it goes quite well in reverse. Now I have to understand the mysteries of the futaba 1 ms vs 2 ms and get the sounder installed. 

    • Admin


      Since you are not using the throttle joystick on your Futaba R/C transmitter you need not be concerned with the way the throttle channel works.

      Your response to the way that you are using the aileron and elevator joysticks is correct.

      Sounds like you may have an APM power supply problem.

      Are you using a Power Module or a BEC?


      TCIII ArduBoat Developer

    • Power Module (PM) with it's own battery. And that works okey for the APM.

      I need to check the voltage when I get home (I'm at the cabin now, and have forgoten to take a voltmeter with me.)

      But going forward is still burst, going reverse is okey. 



  • Admin

    Hi Carl,

    Here is your RC_MAP parameters from your Full Parameter List file:


    First, some basic questions:

    Are you using the elevator (PITCH) joystick for the throttle input or the throttle (THROTTLE) joystick for the throttle input to the APM?

    Are you using the aileron (ROLL) joystick or the rudder (YAW) for the steering input?

    To what APM servo outputs do you have the left and right motor speed controllers (ESC) attached?

    You do know that the Futaba throttle joystick output is the reverse of normal R/C transmitter throttle outputs (ie, the throttle output is 1.0ms when the throttle is full up and 2.0ms when the throttle is full down)?

    Response to these questions will help us to get going on troubleshooting your problem:-)


    TCIII ArduBoat Developer


    • HI Thomas,

      Thanks again for using your time to help me :)

      If I understood the joystick layout right, I'm using the elevator joystick for throttle, (that's the right joystick right?) and the Aileron joystick for steering (same joystick, just the other direction)

      Left motor is output #1 and the right motor is output #3

      And, no, I didn't know that Futaba was any different. 



This reply was deleted.