Initial Configuration Fail

First Post, so I'll try and be concise. Received X8+ RTF 6/22. Charged battery and flew manual for initial test. All well with only personal tuning notes since I'm experienced pilot.

Installed Mission Planner on Laptop and Surface Pro. Connected to Copter and initiated "Initial setup". Uploaded firmware and went through the configurations.

Copter now reading bad battery voltages around 11.5 Volts and goes into critical signal cycle (low Battery). Fully charged battery with tested output of 16.7v.

I'm stuck, but think I'm in the right place for remedy. Not one to moan on open forums like a baby, just want to solve issue to move to productivity stage.

Second ? is about the preconfigure wiring on the X8+ RTF. I'm configuring for Canon 260 and wondering if the wiring at nose for Parrot gimbal has one setup going to the Aux ports (occupied 1-3).

I look forward to a long relationship in this group. Jay

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Power Solved:

    Now, about the preconfigure wiring on the X8+ RTF at the NOSE. I have mounted a vibration isolation plate and camera "clamp". There are three distinct connectors at the nose. One is at bottom, teow is an apparent power feed (top), and the thirsd is a 3 wire female (top). Aux ports (occupied 1-3).

    I'm configuring for Canon 260 and wondering if the wiring at nose for gimbal has one setup going to the Aux ports (occupied 1-3).for camera trigger that I can connect to the micro usb tail cable I've started to make (need connector @ hobby store).

    Thanks, Jay

  • Hi Jay

    Have a look at this:

    Preety much says it all, if it's indeed the battery config that's missing.

    Best. DP

    • Thanks for your reply. Battery issue solved as noted in reply to Frank above.

      Any insights on the Camera configuration now would be helpful.

  • Since you purchased the X8+ RTF I assume it was all set up and tuned/configured when you got it that is why your initial manual flight went well.  I am only speculating here but when you installed mission planner and updated the firmware and config maybe the battery calibration got lost or reset.  I Just recently went through a calibration and followed all of these steps:  

    In particular look at the battery config (step 5).  I initially had no battery information being read via the APM/pixhawk power module until I selected the correct models from the 3 drop-downs at the top of the battery monitor page(optional hardware -->battery monitor).  Once I had that set the power module started sending battery information to mission planner and I was able to go through and tune according to the video that was in the link above.

    It is also possible the power module is bad.  However, since you were initially able to fly it I would think that is not the case.

    Hope this helps.

    • Frank, Thank you for your reply! I worked through the power issue successfully by applying FOCUS on each and every parameter. Sure enough, there was a single param causing the bad report of voltage. All set there and AC powers up aok. Thanks.

      Now I'm moving on to the camera trigger question.

    • Great to hear!  As far as the camera setup, unfortunately my experience is limited.  I am confident the more experience folks in this forum can assist with that.  

This reply was deleted.