Using ALT HOLD with a helicopter

Thanks in advance for any Help

I have a Trex 450 clone, Tarot FBL head, APM 2.6 with v3.2.1 firmware, flysky 9X transmitter using heli1 setting.

This unit is wired with the receiver ch3 connected to the APM ch8, and the receiver ch6 to APM ch3, unit flies pretty good with some parameter tweaking.

Need help setting up ALT HOLD, could someone explain how I can set this up in mission planner for a helicopter, I do not know what I am doing wrong, I have used alt hold in Quads with no problem?

I have tried this but as soon as I flip the alt hold switch I get very hard up and down osculations? 


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Tlog will be on your computer if you have flown while linked to Mission Planner via Telemetry.  You can then graph your acc x,y,z vibrations.

    INAV_Z will be in the full parameter list on Mission Planner.

    Honestly don't remember if 3.2.1 is OK with a 2.6 or if the EKF just wont run on it and all will be good. I thought 3.1.5 was the last release for a 2.6 but I could be wrong.

    Trex clones are known for heavy vibration due to bad bearings and out of round gears.  You really need to graph the vibes otherwise it will never fly well.

    As far as Heli mixing from the Transmitter goes I don't know if that will cause other problems.  There was a time when the swash would not move unless the helicopter was armed IIRC.

  • Thanks David

    I have watched quite a few autonomous apm heli flights on youtube  but there are not many discussing their setup,  I know it is doable, I just don't have it figured out? I run telemetry on my unit, not usb cable, so I cannot download a log file? I have tried to plug in a usb cable along with the telemetry wired in and the apm did not like that at all, servos started moving crazy as soon as plugged in? I assume a person cannot have telemetry (wire connections are a pain to get to APM is under belly of 450) and usb plugged in at same time?

    I tried using airplane mode with my Flysky 9X, but swash servos would never move, so had to use Heli 1, 1 servo?

    I have never heard of Inav parameters in mission planner, where are they located?

    Thanks again for help

  •  Also a number of autonomous test flights can be watched on youtube.  SWF Drones is the channel name.  Did a ROI that worked out very well as a test.  3.2.1 works very well once everything is set up properly.

  • I have not tried simple mode.  I fly a 600 size Heli on 3.2.1.  Low head speed, spin blades, and a bit of weight with the various payloads.  You need to check your vibrations on the z axis to make sure they are not to high.  A log with mission planner will graph this.  The INAV parameters are also somewhat important for Alt Hold.  Also I run a fixed head speed with no mixing in the transmitter.  In other words my Heli transmitter is not set to Helicopter but set to fixed wing.

  • David 

    Thanks again

    You seem like a experienced APM Helicopter user, Question have you tried Simple mode with Stablize flight mode?

    I have a GPS and Compass I could install if I thought it might work, I have had good luck with Simple mode with Quads,  this would be real helpful with a heli?


  • I run mine at .3 .  Try it with more altitude and be ready to switch back to stabilize and hit the collective.  It could also be some other parameters or a vibration issue.  Post a log and parameters and I'll have a look. may be a better place to post this.

    ArduPilot Open Source Autopilot
    The most advanced open source autopilot for use by both professionals and hobbyist. Supports multi-copters, planes, rovers, boats, helicopters, ante…
  • David

    Thank you for reply

    I have tried THR_ACCEL_P with very bad results, mine is back to default 0.5 now and I am scared to try it again?

     I had read on on a forum someone said to turn your THR_ACCEL_P down to 0.1, I tried this and as soon as I hit the switch the heli went full negative down pitch driving it into the ground? 

    Do you suggest trying again with what setting?

    Thanks again

  • Try turning down your THR_ACCEL_P.  What is it set at now?

This reply was deleted.