Greetings all. First post so bear with me, I'll try to make this as descriptive as possible to help a poor soul who follows me down my path of pain. I'm building my first 3DR Y6B UAV and am running into issues calibrating the radio, or at least I think I am. I've searched the bowels of the internet forums looking for a solution, and I've wound up back where I started, which is here.

So here's where I've been in the meantime..

I've got a Spektrum DX7s and AR8000 that appears to be bound (solid orange lights on the transmitter, solid orange lights on the AR8000) although once the AR8000 is disconnected from the power source and plugged into the Pixhawk SPKT/DSM port, the light disappeared. One of the forums said thats ok, so I ignored. Attempted to power on the transmitter, solid orange, but when opening Mission Planner, there were no values on the Radio Endpoint. Read more forums, thought this 6 channel config on the transmitter might make the difference (nope, but its my current setup), discovered many threads talking of issues with the SPKT/DSM port and AR8000 plus not as great of range, so I ponied up $24 and ordered the PPM encoder.

Wait for part for 12 days....

Plugged in the PPM encoder, fired up the transmitter yet again, went to the Mission Planner Radio Endpoint calibration screen, and this time, values! Smiles filled the room,hHowever, upon attempting to calibrate my still solid orange transmitter and slowly blinking blue PPM encoder, attempts to put the throttle up, down, left, right, anything, resulted in zip.

Smiles faded. Back to forums, back to here.

I'm doing something stupid, I dont know what it is. Please tell me someone here has felt my pain and can get my 3DR Y6 up in the air.

Thanks in advance for the help.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Do you have any other radio to try with?
    Check that your px4io firmware is updated if your running 3.2. I had this problem when I upgraded from 3.1.5 to 3.2rc10. Check your boot log on the sd-card I think it says its trying to update the px4io firmware, though there is no check to make sure it worked. My problem was solved by forcing the px4io into bootloader mode at startup.
    • I don't have another radio currently, was hoping to avoid that by exhausting my options here first and making sure I wasn't doing something stupid on my end first.

      Regarding the firmware, I am assuming you are referring to step 3 outlined here ( I will give it a try this afternoon, pretty sure I haven't attempted an update to 3.2.x yet but its been a long 3 week struggle so anything is possible. I was planning on upgrading to 3.2 anyway, so lets hope that solves the issue.

    • No, this has nothing to do with windows drivers or PX4Flow.
      This post and the ones above describes the problem and solution
      Have you tried disconnected everything except the ppm sum receiver to the rc in port and the USB cable?
    • Was able to get the firmware updated to 3.2 no problem, but the original issue remains. Was attempting to disconnect everything and damaged my buzzer cable, so I guess I have something to do tonight. :(

    • Disconnected everything except the PPM and the USB cable, Radio Calibration page remains the same. There are values, the DX7s is solid orange and full throttle does nothing. It would be a heck of a lot easier if one of the 4 systems would indicate its not working, other than the Pixhawk itself saying RC not calibrated.

    • 2 weeks and 2 wires later, turns out it was a defective wire between the PPM Sum and the receiver. I told everyone in post 1 it was going to be something stupid.

  • Quick observation.  You can't plug an AR8000 into a Pixhawk SPKT socket.  

    You can plug the satellite receiver that comes with an AR8000 into the Pixhawk SPKT port.  You need the AR8000 initially to get the satellite bound to your transmitter but then you can put the AR8000 aside and just use the satellite.

    if you don't have a satellite receiver, or you really want to use the AR8000, then you need the PPM encoder which you need to connect 8 PWM cables from the AR8000 to the Encoder on one side and then a single cable from the Encoder to the RC pins on the end of the Pixhawk.

    • Thanks, I meant I plugged the satellite from the AR8000 into the SPKT port, but I should have been more specific. That was my initial setup before I ponied up for the PPM encoder and followed these instructions:

      I have numbers in Mission Planner instead of zeroes, but nothing more.

This reply was deleted.