Y6 with the shakes

Hi there

Hoping someone might be able to shine a light on this problem:

  • Stock 3DR Y6  B config
  • ESCs calibrated
  • Props balanced

Watch video

When I add some throttle, the frame shakes violently (as seen in the vid). I get the same result regardless on whether the copter is restrained or not.

When not restrained and I add throttle, there is uncontrollable yaw (spinning) -  RC stick input seems to improve this but not much.

I am sure there must be something simple that I am missing. Any suggestions?


Nigel - Uaviation

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Have you done the "compassmot" calibration / test?
    My Y6 had bad yaw drift until i ran compassmot and saw high interference.  I twisted the wires to my compass and re-ran with much better % and the yaw drift is now gone....

    • Yes, thanks for your reply Brandon I have done calibration and test - all good. 

      I am going to run some detailed motor logs as Ed has suggested. I will take another look at compass mot while the motors are spinning.

      Stay tuned for the results!

  • Aside from the prop balancing and prop direction thing, I would consider enabling the motor logging function to see if the yaw wiggling is a commanded motion (the motor speeds would also rapidly fluctuate) or whether it's an airframe oscillation from something being unbalanced.  If it is in fact a commanded yaw oscillation I would reduce your yaw P value by half and adjust it from there.

    BUT that won't help the spinning situation.  Increasing your yaw I value would improve that in theory but it really shouldn't spin in the first place.  Make sure you have a good compass calibration and declination set, then test it while hooked up to Mission Planner, flight data.  

    Do be sure to have a fresh radio calibration as well.  The APM does need to have a valid center stick position to work with.  ou may have the stick physically centered but the APM is receiving what it thinks is a yaw command.  I goofed that one once after inadvertently trimming the yaw.....long story, silly mistake.

    Good luck man!

    • Hi Ed,

      Thanks for your thoughts - I have had motor logging on and have checked it - nothing jumped out at me. I am going to have another look.

      So if motor and PIDs look okay you think the airframe might be un-balanced? Would an un-balanced airframe have these symptoms when it is anchored or only when it is free?

      I will start by replacing the chip. If that doesn't work I will try the airframe. If that doesn't work I will try the bin!

      - I will keep you posted of the outcome 

    • That's a tough one my friend.  I would have looked for fine sine waves in the motor outputs, 180 degrees out of phase for each arm motor pair, but it sounds like that's not observed in the logs.  

      By "airframe" in only mean all the physical parts besides the APM controller, so motor mounts, motor bells, and props, but it sounds like you already checked all that.  In theory, if you did have a mechanically loose or unbalanced part I might expect the oscillations you showed, but again, it looks like you covered that part.  Do you feel pretty good about the solidity of the APM-to-airframe mount?  Could the APM be chasing it's tail about the Z axis?

      It intuitively looks like a proportional (P) feedback, maybe made worse on the static stand by the resonance of the landing legs, but that doesn't explain the same behavior in flight. It's a very fast oscillation like an overly sensitive P setting.  Damn that is frustrating!

      I think if it was me i would turn down the yaw P to nearly zero, so it was fully manual Z control, and see what happens.  Sorry this is happening to you, but I am eager to learn your solution.


  • Is that a new build?  Are you sure the props are all on the right way up (writing on top - even the bottom props).  B config chosen in software and motors all spin the right direction and the right props on each motors?  Run CLI motor test or just plug motors in one at a time (1 = top right, 2 = bottom right, 3= top back, 4  = bottom back, etc).

    • Thanks for your reply Brendan

      • New build (by me - not rtf) - yes
      • Props correct - yes
      • B config - yes
      • All motors and prop rotations confirmed - yes
      • All motors are working fine and correct order - yes

      I have several 3DRy6 running different chips, A and B configs etc etc..

      Those were all the first things I checked. I figure that this issue is a little more complex than a missed step in the setup process but it is good to do that double check.

    • It sounds like you've got plenty of experience with these things then! :-)  

      The overall yaw obviously means there is an imbalance between clockwise and counter-clockwise torque.  If you're sure that it's not a physical setup issue then that points to something in the controller.  

      I assume your in stabilise mode?  Perhaps the next most likely candidates are RC (yaw) calibration and compass calibration.  Are you using an external one?  

      Regardless that's about the full depth of my guesswork sorry - good luck getting it sorted.

    • Thanks Brendan - I will take a look at yaw calibration

    • Sorry just took a peek at the video and saw the external compass.  As suggested below, some logging might by in order.  Cheers.

This reply was deleted.