ArduCopter V2.9.1 Accel Calibration

I've been trying to calibrate the Accelerometers since the day 2.9 has come out and have not been successful yet.  Here is what I've tried using the mission planner calibration method.

  1. Powered via usb (both on my quad and off)
  2. Everything connected/nothing connected
  3. Powered via lipo battery sending commands over telemetry
  4. Completely resetting the EEPROM, and the code
  5. Changed the filter value
  6. Sending the commands via the CLI

Every time the calibration fails and i'm left with values like:

INAV_ACORR_Y -59.582




I've been to scared to try flying it to even think about doing the auto trim method.

I've read around the "ArduCopter 2.9 / 2.9.1 released" thread and it seems like there might be a couple of others out there that are having the same problem

Any help would be greatly apprecieated

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I've got a board that can't be calibrated, even with the more relaxed threshold in Randy's custom firmware.

    These are the values I'm seeing when I do the calibration in the CLI:


    Bad board?

    I'm guessing modifying the code to have a threshold of 7.6 is not a great idea, if it's that far out.

  • hey guys

    loaded the "relaxed" version and had some nice results

    Log and KLM attached,

    as side note randy i have my TC set to 8 and im quite happy with it up there.... drops are only about 1-2m. im sure you could see that in the logs.


    2013-04-01 10-11-07.tlog.kml

  • Developer

    I've created slightly modified versions of 2.9.1b here with more forgiving accelerometer calibration checks.

       APM2.x quad is here.

       APM2.x hexacopter is here.

    So if your accelerometer calibration is failing you could try uploading these through the mission planner's firmware screen.  On the bottom right you'll see the "Load custom firmware" link.

    Please note that these are for the APM2 or APM2.5 only.

  • Developer

    In fact, this tolerance check is only stopping the final save of the new scaling and offsets to the eeprom.  If you knew what those values should be then you could enter them directly into the mission planner's Adv Parameter List.  Sadly it appears that when we fail the calibration, although we display the new scaling and offsets from the calibration algorithm, we sadly don't display enough digits of accuracy for you to make use of them. close and yet so far.  :-(.

  • Developer


        Ok, so the issue is probably that your Z accelerometer offsets (2.953) is very close to the limit which is 3.0.  "3.0" was picked because it was a bit worse than the worst board on the dev team.  Your board seems to be very close to that.  The numbers that you've got above are probably from the old "level" procedure which didn't have the tolerance check.

         I can easily provide a version of the code with the tolerance check increased (maybe to 3.5 or 4.0).  Do you think you could upload the code with Arduino or would it be easier for me to provide a hex?  If it's a hex, are you running an APM2 quad?.

         If anyone can point me to other people having this issue I'd like to sort them out too.

  • Use 2.9.1 and MP 1.2.33 and problem will be solved i think..

  • Hi, i had the same issue with mine when updated the planner to version 1.2.32, so i decided to re-install the ver. 1.2.30 , and problem resolved.

    p.s - i haven´t tried yet with the latest ver. 1.2.33, so i can´t comment about it.



This reply was deleted.