I can´t configure esc with pixhawk.

Hi, I'm new in this forum.

I have come here looking for a solution for my pixhawk, but I have not found it.

I have an F450 that was flying well. I upgraded to version 3.5.7 and started flying by moving a little to the left (it also suffered a blow, I do not know which of the two things caused it, whether the update or the blow).

The fact is that I thought it was because I had not calibrated the ESCs. I tried to calibrate them like other times but I did something wrong and now I can not calibrate them or build the drone to fly.

As you can see in the video, in calibration mode I'm going up the gas and the engines start from less to more until they stop and so on several times while I'm raising the gas. I do not know, something strange happens.

I try too downgrade to 3.3, 3.3.3, and others versions, but I always get solid red light on pixhawk that indicates error and I can´t do nothing. I do not know why.

By the way, the ESCs are these: Racerstar RS20A 20A BLHELI_S

VIDEO1: https://mega.nz/#!qEZjhAYD!fW3MQfPRQtxNgIQIo3-r5kzqOHrz9SZRAF9MTSZr1v4

VIDEO2: https://mega.nz/#!XZYSGKgB!LpD3uP5XkS-pvMhNKIZwsvJDTi1MMIMAiIhdWCZ9XRM


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I looked at the pictures you posted and I realized I have seen this before.

    What caused this was I had flashed a Pixhawk new firmware and Mission Planner wanted to know if I wanted to download ChibiOS which is the Real Time Operating System (RTOS) that replaces NuttX.  

    To resolve the issues this causes I flashed the Pixhawk with firmware for and airplane.  Immediately after the airplane firmware flash was finished I flashed the Pixhawk with firmware for a Quadcopter and I selected NO when Mission Planner asked if I wanted ChibiOS.

  • Anybody can help me, please?


  • Y try change other micro sd, format micro sd fat 32, calibrate compass...

    another after setting the compass and restarting the pixhawk:

  • The Throttle is ok.

    Look this.. Maybe help to find my problem. 


  • This can happen for a number of reasons.  One problem that is often over looked is the Throttle channel IN THE RADIO may need to be reversed.

  • Oh thank you very much.

    You have made me understand some things that I did not know.

    I have managed to calibrate ESCs in the way you comment, with the OneShot protocol, I did not know that each ESC had a different protocol.

    Once calibrated, I built the drone without the propellers and it worked fine.

    Then I was calibrating the accelerometer and the compass with the wizard, and putting the failsafe and I was not armed with the drone, I thought it was a GPS problem and I took it to the street to try it, but I could not put it together.

    The flight modes I have are "Stabilice", "AltHold" and "Loiter". In no flight I can put the drone together.

    Do you know why it may be due?

    Thank you very much for your help!!

  • If you are having trouble with Pixhawk booting, try flashing a different firmware like Rover, Airplane, or Helicopter, and then flash with Copter 3.5.7 for a Quad frame.  Flashing first with a non-copter firmware will completely over write Pixhawk memory and clean up any corruption so you can get a clean installation of Copter. 

    For the motor/ESC issues, props off bench testing using the radio is totally useless.  When you arm the motors the PID controllers are ACTIVE.  Pixhawk is trying to control an aircraft that is not flying and the motors will behave erratically.

    Second, you need to connect Pixhawk to Mission Planner and go to Initial Setup > Mandatory Hardware > ESC Calibration.

    Set the ESC Type to match the BLHeli Protocol (OneShot, OneShot125, DShot, etc.) you are using,   then click the Calibrate ESCs button and  follow the instructions.

    Third, the ONLY method to use for props off motor testing is in Initial Setup > Optional Hardware > Motor Test.  Be advised that the testing sequence A,B,C, D does not match Motor Order.  During Motor Test, Motor A is RIGHT FRONT, Motor B is RIGHT REAR, Motor C is LEFT REAR and Motor D is LEFT FRONT. 

This reply was deleted.