hi all

Got a bit of an odd one going on here.

I am trying to configure the Fail-safe option, Mission Planner/Pixhawk does not detect when I turn the radio off so it will not trigger Fail-safe.

If I start mission planner with the radio turned off, it correctly shows no radio and as soon as I turn it on it correctly shows its connected but as soon as I turn it off to trigger a fail-safe the screen still shows the radio is connected even though its off.

I am using a Turnigy 10 Channel system connected via PPM, all other aspects work but this one has got me stumped and is preventing me going out flying, anyone got a clue as what's gone wrong here.

Thanks for any help


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Thanks again for the help guys

    Right, just calibrated the Transmitter again and noted down the minimum reading for Channel 3 the throttle which was 1000 and in the Fail-Safe screen set the value for the throttle to below 1000, it was at 995 by default and then powered down my radio and the value of the throttle stayed at 1000 so no fail-safe triggered.

    I have also tried setting the fail-safe in the receiver to -100% and that made no difference

    Just to test something in the fail-safe setting I moved the throttle up to a reading of around 1200 set the level for trigger to 1005 so above the throttle minimum.  then when I lowered the throttle back to its 1000 minimum the fail-safe triggered and then reset when I again moved the throttle above 1005. But it still does not work if I Turn the radio off, If its at 100% throttle when the radio is turned off it stays at 100% throttle.

    Something very odd going on here, almost as if the receiver just remembers its last setting at radio link lost, nothing in the receivers setup pages for that though.


    • Tell us EXACTLY which transmitter and receiver you have.

    • I am running the Turnigy i6 Transmitter with the 10 Channel Firmware and a Turnigy i10 receiver

      Just tested one more thing and pulled the reciver to Pixhawk connection and the Pixhawk went into failsafe without any issue.

      So its looking more and more like something amiss in the way the receiver works when the transmitter is turned off.

      I have tried all settings in the receivers failsafe menu, all on, all off, throttle at -100% throttle at +100% and it all made no difference.

      It does work fine when used without a flight controller though.


    • Just double checked with a Turnigy i10 transmitter as well and got the same result.

      Just to eliminate it being an issue with the patched 10 channel i6 firmware.


    • looks like I have the fail-safe sorted now

      to get it to work I had to go into the receivers fail-safe menu and set the value of -100% to the first 6 channels, once that was done fail-safe worked as expected on transmitter turn off.

      Hope this will be of help to some else using Turnigy/Flysky gear.

      Thanks again everyone for your help with this.


  • It looks like your RECEIVER FAILSAFE to "Hold what you have."  You need to set the RECEIVER FAILSAFE to NO PULSES. 

  • Thanks for the replies

    The problem is that its not seeing when I turn the radio off, in mission planner on the Radio Calibration Screen it still shows a radio connection when I turn the radio off.

    It has no need to go into fail-safe if the radio link is being read as ok does it.  That's my limited understanding.


    • The radio can be detected only using the Throttle values. This is the way failsafe working.

      When you calibrate the radio, you should write down the throttle min value - Tmin for example 1072

      Then, looking either the calibration screen or failsafe screen, just switch off the radio. Write down the new, radio off throttle value, Toff for example 902.

      Calculate the failsafe value: (Tmin-Toff)/2+Toff= (1072-902)/2 + Toff = 987

      The Failsafe throttle value is then between the low calibrated throttle value and the no transmitter value, that for sure will trigger the FS!

      Just write then the FS value 987 in the FS Pwm window.

    • The Turnigy stock 9x receiver can be set FS:

      Switch on tx and receiver.
      To set failsafe, move and hold the corresponding stick at the wanted position. Press and hold the pushbutton switch next to the binding LED of the receiver untill the led is flashing. You may release the switch, but hold your failsafe position of the stick. When the LED stops blinking, LED is permanent on and failsafe position has been stored.
      Release the stick and power off radio. Value goes to failsafe position and holds the position.

      To have get proper FS value, you should put some stick offset before that procedure, to get the FS value at least 100 less the normal low throttle value.

  • It's easy.
    Lower your throttle min value to less than 950 pwm, then rebind the receiver with your transmitter.

    After rebinding reset your throttle min value to the original about 1100.

    That way when you turn off or lose radio signal, you'll enter failsafe mode.
    That's all simply put, but read more about it here:


This reply was deleted.