My New High Effecient Setup Getting Ruin - Low KV quad

Hi there!

For the past 2 month I'm using APM 2.5 with 2.8 firmware. I'm using HK 550 frame. Electronics from my old gaui (1100kV scorpion motor and it 15A esc).

It fly fabulously! Love it so much.

On last Monday I start build up my new setup for my Quad. My plan is to have high efficient quad.

My new setup as below:

Frame: old frame HK559

Motor: NX-4006-530kv from HK

Esc: Multistar 30A ESC(opto)

-I think this ESC doesn't have throttle calibration. I can't find it. It not as usual ESC

-Due to Opto type, I power up my receiver using APM power module.

Prop: Carbon Fiber prob 13X4 from HK

After all hardware put together, i update firmware to my APM using 2.91 version.

I done all calibration process as request.

Everything seem OK.

Flight Test Result

When i fly my quad, i found my quad not stable enough.

After I make forward flight, it getting worst. I need to hold forward pitch and roll stick in order to make it stable. My quad tend to move backward.

When I apply yaw, my quad tend to backward and tilt on the side.

After that, I make auto trim by push rudder 15sec as mention in the manual and hover it about 40 sec.

After done auto trim, it fly well when hovering.

Then I make some forwad flight.The problem come again.

It getting tend to backward. After a second it tend to the right. it getting worst.

Then. make auto trim again. It good in hovering, but after forward flight it lost the stabilization again.

After some test, i plug quad to mission planner. I saw in 'Flight Data' that my quad is not stable eventhough pysicaly it stable. I think this is the root cause.!!

Next, I re-upload again 2.91 firmware and make some adjustment on the PID as below:

1. Stabilization P rate: change from 0.145 to 0.09 (0.09 because I think my motor is big not like last time gaui 1100 KV)

2. I make 'Stabilize Control' can adjust to my ch6 knob from 4.5 to 5.3

I make field test again. The result is same eventough I increase 'Stabilize Control'.

The sad thing is the tip of my carbon prob getting tear off due to some crash during hovering and landing.

After second test, I plug again to Mission PLanner.

I saw in flight data my quad not stable again.....

I think there are some problem for accelerometer in my APM..

Attache is picture of my quad

Somebody please help me to give some idea for this issue??

What the actual root cause??




You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi all,

    Just now (11pm in M'sia), I manage to fly using firmware 2.9.

    It fly perfectly.. It can hover, forward flight, loiter and alt hold.

    I think problem almost solve!

    Anyway, I realize that I cannot make 'Auto Trim' (by push rudder to the right).

    If I make 'Auto trim' my quad will not level anymore.

    It can be check via HUD in 'Mission Planner'.

    2 time i try. But the result is the same.

    So, I can't make Auto trim.

    Anybody can advise why I cannot make Auto trim??


  • MR60

    Hello Khalid,

    Due to your erratic quadcopter behaviour, I would try a full EEPROM APM Reset. I have read other threads where this has solved some strange behaviours. A reset is not only reloading the 2.9.x firmware on APM, it really means completely erasing the content of your APM. I think you can do this from the CLI command from mission planner.

    Another idea : check that your quad is physically well built : everything is geometrically not unbalanced, for example check that engine mounts are straight , quad arms are in the same plane, etc.

  • FYI - I had a similar problem that took me the entire day to get working. It turned out that the ESC calibration procedure only calibrated two escs on one side. It would still fly but ended up breaking a few props and changing PID values. I was ready to give up and then I decided to try recalibrating the SimonK flashed ESCs one more time. This worked, and with default values my copter is extremely stable.

  • For this motor (530kV), What is correct 'Stabilization P rate' setting??

    0.09 is for big motor. Is it Correct?

    What is class for this motor? Big or medium??

  • It may be a vibration problem. Going from 2.6 to 2.9 with the same mount made our flight much less stable. I added some foam to dampen vibrations and that solved the problem. You may want to try some sort of vibration dampening or trying an older version of the code that does not rely so heavily on the gyros just to test

This reply was deleted.