There probably is an easy explanation, but after two days of trying different things:

  • Tried with Mission Planner
  • Tried with APM Planner 2.0
  • Tried with DX8 RC remote

we still cant get this thing into liftoff.

We have a steady telemetry signal and when we move the copter around we can see the variables change from in the groundstation. We've calibrated the compas, acceleration, radios and setup frametype and flightmodes.

I have attached a video of the state of error, in the hope that some of you have seen it before and knows what it means and what we're missing.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Update:

    We had forgotten to do compassmot calibration as well..

    We saw Randy's videoguide, but instead of tape we used our hands to ensure it wouldnt move. The drone didnt move but one of the propellers fell off and I'm now one small flesh wound more experienced. We then tried it out again using Peters approach, but with our strips of textile we couldnt really ensure that an equal amount of pressure was being applied to all motors. But at least with this approach we could register a level 60% interference which was lower than before. The manual indicates that <30% is the optimal..

    For impatient noobs (without RC background), this is really a blood, sweat and tears project. The manual is good, but right now there's one thing we would have liked to know earlier: The COMPASS_LEARN parameter. In our system it was disabled, but after enabling it and applying slight throttle to the drone while on the ground we see that our magField measurements decreased from 700 initially down to about 350 which should be optimal for the APM2.5 board and it behaves more stable than yesterday..

    Our battery then exhausted so we will resume again tomorrow.

  • Thanks for the input, and that was exactly these things that were wrong. We went through the manual to make sure we didnt miss out on anything else. Basicly we did a check for:

    • Compass calibration
    • Acceleration calibration
    • Radio calibration
    • ESC calibration
    • Propellers turning right direction

    And this all went well so that we can now arm the copter and apply throttle with our Spektrum DX8 transmitter. We do have an issue though in that our left and right rudder has become reversed so we have to hold the rudder down and to the left instead of to the right as the guide says.

    We are not fully airborne yet as we observe that whenever we apply throttle halfway full, the copter starts to lean onto its nose as if the pitch is maladjusted. We have tried using this guide to tune the pitch but havent found a combination that convinces us yet that it will be ok to apply full throttle.

    I have attached the logs I could find inside MissionPlanner, (is that the logs you meant?).



  • I've seen the same behavior from a motor/ESC that hadn't been configured "set up" properly with the transmitter.  If the auto setup isn't working, I'd go through and manually set up the motors individually as the wiki recommends.  As the info states, there are lot's of ESC designs and set up protocols.  I've got one that resets every time you pwer it on.  I have to manually calibrate it every time.  That's my two cents.  Good luck with it.

  • Randy Mackay has a good YouTube video on the pre-arm checks the APM goes through in ArduCopter 3.0 and later. I'd suggest you view that video, then look at your log files the way Randy did and see if there's something in your configuration that isn't allowing those checks to complete successfully.

    Randy's video is at

  • Did you configure the ESC's?  I believe thats part of the setup, dunno, been a while since I assempled mine.

    I say this... cause I worked on a car for a week to get it started...  I never check if the car had gas...  put gas in it and it started right up.  Could be something as simple as setting up the each ESC.

  • Right, your video link says "file corrupt", I can't view it.......

    So, basic fault finding, 5000+ users can't be wrong, so, you missed out somewhere in your setup.

    My gut feel would be that Greg is on the right track.

    What "mode" is your radio set up ?

  • What Greg said.  Also, make sure your rudder controls move the yaw indicator in the right direction.  My "servo" was reversed and no matter what I did it wouldn't arm until I figured that one out.

  • My only suggestion is make sure the hexacopter is in stabilize mode. Then arm the hexacopter by holding down to the right on the left joystick. 

This reply was deleted.