TBS Discovery & Pixhawk load of problems :(

Good morning DIY DRONES,

You guys are my only hope as I have tried everything I can to fix this problems but it seems like an never ending journey.

So, let's me start by saying that I have followed and researched about every possible way to build a TBS Discovery with Pixhawk but my knowledge is still very limited, as I keep on reading, I feel like I have made so many stupid mistake.

So my TBS build list:

TBS Discovery w/ core.

900kv TBS motors and bulletproof escs

9x5 propellers

Pixhawk w/ GPS

4500mah 4s battery.

I have been facing so many problems since thay day I switch from 750kv to 900kv, as everybody said the samething, 900kv is way much better, better bearing, i choose 900kv for long flight etc...

After I install the 900kv on my tbs, everything started to fall apart, Mag_field is really high, over 680 :( Vibration is absolutely ridiculous (eventhough my X+Y axis is still under range but my Z is way beyond measure). My quad could not hold position or altitude, when I fly in stabilize mode it seems to be okie but when i switched from stabilize to either Loiter or Altitude hold, the quad started shooting up and down just like when you change throttle from lowest position to highest in a matter of second. I have to switch to stabilize mode immediately other it will keeps going up.

Could you guys please help me to make this right, i'm truly desperate, i have tried everything but non of them seems to work. 

Please find my attachment for the log file, i have tried to fly it as long as i can to review the problems. Please DIYDrones, you are my only hope. 2014-09-12%2023-29-04.log

P/s: I have calibrated all escs,  compass, etc.. I followed the introduction closely but non seems to work




You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • I agree. Time to rule things out like the I2C splitter. I just had an issue where external LED would not work via the splitter but did with a direct connection so who knows maybe the compass isn't working %100 through the splitter.

      The Pids though aren't crazy low for a really light frame. My heavy frame auto tune had the main three pids around 12. However the one I have right now is very light and flights great with 4.5 on all 3. Alt hold and loiter are 1 just like he has. My throttle rate is 5 not 6 but I certainly don't see anything jumping out at me as way way off PID wise. Gotta be a bad cable or other hardware issue. Just a guess for course.

    • @Kristian Olson,

      lol.. thank you for your comment, whenever i hear somebody calling my name, I got a very happy feeling :D :D

      My exact problem right now is that my quad is very unstable whenever i switched from Stabilisation to Loiter or Altitude mode. It keeps jumping up and down and doesn't hold altitude at all.

      For the I2C splitter board, I have removed it out of the equation (it used for external usb and led). I have no camera, no fancy stuffs mounting on my quad at the moment. The only extra is the telemetry.

      I will definitely try to update my firmware and see will it help or not. And my Pixhawk is authentic 3DR just like any of its components.

      Many thanks :D

  • Just a shot in the dark but are you sure you have the prop spacers in place? The small black spacers that make sure the shaft fits perfectly with the prop? 

    I have had good luck testing for vibrations by CAREFULLY holding the quad and throttle up about 1/3 and then rotate it around up and down a bit and you can clearly feel if there is one motor / prop out of balance. 

    • @Richard Kennedy Prop spacers are in place, my new propellers are from HK, i have balanced it (i would not say that it is perfectly balance but it will do the job :D). If you see in my video, everything is wrong at the moment.. lol, I don't know what to do any more. Just don't want to give up but well, if this problem still existed, I would go back to either APM or Naza :D

  • If you have tried re calibrating the radio input, compass cal and accels etc. then re install the original 750Kv motors and see if you have the same problem. Then you will know if the motors are the issue as from what I understand these issues started when you replaced the motors.

    Also, I don't know if its a smart idea to have the telemetry radio mounted near an esc.

    • Also if you are not running the V frame type try it.

    • @Ben Carson: I have done all the calibration very careful followed by repositioning of the GPS and MAG. Tried to install 750kv again yesterday and the problem is still there, eventhough it is not that aggressive compare to 900kv but it is still there (it was there when i'm using 750kv from the very beginning). For the telemetry, I have mounted it in the middle of the frame now instead of below the ESC like I used to, so it is does help a lot of the Telemetry range. Also, I have tried both H and V and the above video was on V not H.

      p/s: I notice 1 strange thing when i run the Compass Calibration (Declination), after 60 second the procedure is done, declination pop-up but it doesn't show up in degree (it is still showing 0 and 0 in my case). So do you this is one of the problem? 



    • "re-after 60 second the procedure is done, declination pop-up but it doesn't show up in degree (it is still showing 0 and 0 in my case). So do you this is one of the problem?" 

      Funny you mention that I noticed that too since rc10 I think. Are you using Mission Planner or Droid Planner just out of curiosity? 

    • I'm using Mission Planner and APM planner (both lastest version).. but both of them are showing the samething.. lol.

  • Update 5th October 2014,

    Sorry for the late update, i was really busy lately. And everything is still the same :( I have tried every possible way already. It seems to me that I have no luck of flying Pixhawk :(.

    I took everybody advise on everything, from twisting the wires, 3d printed anti vibration mount, etc... but the problem is still there, here is the video for it. Please accept my apologise for the video as i have to mount it on my Tx, but you can hear the sound of the motors very clear. Here is the link for the video (it started at 0:35).

This reply was deleted.