And my Iris+ just went away...

Sad day. After good trials with original battery, very easy loiter mode, stable, gentle landing... real pleasure.

Today I changed to spare battery (Turnigy Multistar 5200 mAh 3S 11.1V). Switch on, proper blanking green, but as soon as I give some throttle the Iris jumped approx 20m in the air and started to run straight like crazy. Impossible to follow. Lost.

Do you think only the battery change could have done that ?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I had a very similar experience, first several flights no problem.  Then I was trying to take off gently and just shot up and I did not seem to have any control.  Fortunately it Hit some overhead power lines and fell to the ground so I did not loose it.

    After searching the internet and trying to figure out what went wrong, I figured out that I had re-calibrated the ESC accidentally, by plugging in the battery and then disconnecting the battery and then reconnecting the battery. so when I gradually increased the throttle it just took off like full throttle.

    After re-calibrating the ESC the next flight worked perfectly, however I have experienced several flights where just after takeoff, very erratic behavior, (And Several Crashes) I believe this is because of the gyroscope issue. Waiting on some new props to test, making sure not to move Iris+ while the gyroscope is calibrating.

  • Developer

    Hi Pascal

    Sorry to read about your flyaway.

    The compass and accelerometer calibrations and the vibrations look fine.

    It looks like the vehicle was being moved while the gyro was being calibrated at the start of the flight - the time when the LED is flashing Red and Blue.

    3701866269?profile=original

    You can see the DCM Yaw diverge from the EKF Yaw throughout the flight

    3701866137?profile=originalRoll and Pitch also diverge indicating something is wrong but the culprit is yaw because the copter is heading in the wrong direction away from home as the vehicle is attempting to RTL.

    We have recently made a change to the flight code in the beta of 3.2rc14 that detects if the vehicle is being moved while the gyro calibration is taking place and handles this fault better.  I suggest you download that code from the beta section of your planner.

    • Hey Pascal, sorry if I got it wrong earlier. I am still learning how to read logs. Hope I didn't cause yup any problems.

      Craig, how do you tell that it is a gyro issue rather than a compass or accelerometer problem?

      Thanks

    • Developer

      Hi Alex,

      I'm glad you are learning to read the logs and it is great that you are helping other people.

      I have looked at a lot of Iris+ logs and with so many identical vehicles we have a lot of data on them. The compass offsets are all very similar and the accelerometer calibrations are all very similar plus all the vehicles are test flown before they leave the factory.  That is one advantage of an RTF vs a One-Off vehicle.

      If you graph the vibration levels they are very small and the magnetic offsets are reasonable.  If you look at the altitude during the RTL there is no indication that it is being affected by vibration.   Normally that looks like the calculated altitude drags the desired altitude with it.

      What we do see is the DCM Yaw diverges from the EKF yaw which is a classic indicator of a gyro calibration issue. That is what is showing in the first graph.

      In fact we recently put a patch in https://github.com/diydrones/ardupilot/commit/0ac3267d520aa3331c6c0...

      to deal with a gyro that has been calibrated while it is moving.

    • Thanks for the reply. That makes sense. Sooooo much to learn but it is great fun.

    • Hi Craig and Alex,

      Thanks for your analysis and diagnostic. So we have an explanation on what happened. Gyro calibration make sense to me as I am working in the hydrographic survey business, and on a vessel almost everything rely on a good gyro calibration. Maybe the documentation should insist on not hurry before the first flight. I am not 100% sure now, but I really think the green light was blinking, and in my mind that did say that Iris is ready to take off.

      Considering parameters, I was effectively confident from start to the fact that all vehicles being identical and tested, there was little chance that factory set up was wrong. In fact after my new calibrations I found very close results on parameters than what I had before. But I have really no experience to quantify even a small amount of change there.

      Thanks Alex and all the others to participate and try to help. We are all learning and this new field is very interesting to discover. After the Iris reception, last week was full of enthusiasm , good surprises and also profound interrogations. To say the least, discovering and learning really kept my mind busy and focused. It is a very pleasant experience I would recommend to everybody.

  • Sorry for the newbie question but, shouldnt we try to arm on loiter mode, so it can record home position ?

    • Manuel, it will always record home position when you arm regardless of what flight mode you are in (assuming you have a good GPS signal).

    • Oh... I see. 

      Will it arm in loiter even if it has bad GPS signal ?

  • Hi Pascal,  Great to hear you found your IRIS. 

    It looks like the software was working correctly, it switched to RTL on your command and also RTL and LAND on a fence breach.  This is correct.  It just wants to head to some point far away from you.  Have you recently updated firmware?

     I am no expert but it looks like you might need to check you MAG and ACCEL calibrations. I would do them all again and also run the Compass Mot calibration to deal with motor interference.  

    Your GPS data seems to have a high HDOP right on take off. It jumps up to 2.0.  Maybe you we standing close to the IRIS and blocked some of the GPS sats?  I have had that happen.  Also it seems that the GPS ALT and BARO ALT do not match prior to take off. 

    More importantly there is a mismatch in IMU data recorded (See below) and the EKF seems to be producing some high numbers in its position and height estimates.  From my basic understanding the IMX, IMY and IMZ readings should be around zero and under +/-50 if you compass is calibrated correctly. Your IMX is over 100 for most of the flight and IMY and IMZ seem to wonder around a lot.

      I imagine that any mismatch in IMU data and GPS will cause the IRIS to think it is going in one direction when it is going in another.  Again I would redo all of your calibrations just to be safe and run the compass mot calibration as well.  Sorry to repeat myself.

    As far as taking of goes I find it is best to increase throttle quickly not slowly.  The trick is to get in the air fast but not too fast, so that the FC can stabilise the quad without external forces acting through the legs.  Any slight tilt on the ground will produce a tendency for the quad to put more power to one side.  The same happens if one leg is in slightly longer grass or dirt. These can act together (or against one another to make it seem worse).  Take off with confidence and authority and even if there is a drift to one side it WILL level out quickly, usually before you are 50cm off the ground.  Trust you machine, it will want to level out once in the air!!

    I agree with the other posts, take off in STAB and then switch to loiter.  I always try STAB for take off and then hover a bit then ALT HOLD and hover a bit then POSHOL/LOITER or DRIFT on my first flight of the day.  That way you can be sure that your balance is good, your controls are working and the FC knows where it is.

    For me in an emergency I try to fall back to:

    1:STAB (or ALT HOLD) as your first option.  These are NOT GPS dependant. (If you are uncomfortable with STAB you could use ALT HOLD but you do not have throttle control and if the quad is climbing or falling it may not help).  Practice landing in STAB and ALT HOLD.

    If that does not produce the required return of control then

    2: LAND It is better than flying away.

    I think if you had switched to STAB you would have arrested the flyaway as the IRIS did register you RTL command. The fence breach triggered LAND also seemed to work until it hit the tree!!  If you had tried LAND then I think it should have stopped and defended and you could have had some position control.

    I could be completely wrong as I am still learning how to read log files but my guess is that your compass and or a cell data was off.  As the only thing you changed was the battery you could try testing on the bench.  Try your original battery and run calibrations and compass mot.  Then do the same with the new battery and see if there is any change.  Hope that helps and I am not leading you down the wrong path!!!!

    No of lines 17520
    Duration 0:01:12
    Vehicletype ArduCopter
    Firmware Version V3.2-Iris
    Firmware Hash b212c020
    Hardware Type
    Free Mem 0
    Skipped Lines 0

    Test: Autotune = UNKNOWN - No ATUN log data
    Test: Balance/Twist = GOOD -
    Test: Brownout = GOOD -
    Test: Compass = WARN - Moderate change in mag_field (30.76%)

    Test: Dupe Log Data = GOOD -
    Test: Empty = GOOD -
    Test: Event/Failsafe = FAIL - ERRs found: FS_THR FENCE
    Test: GPS = GOOD -
    Test: IMU Mismatch = FAIL - Check vibration or accelerometer calibration. (Mismatch: 1.89, WARN: 0.75, FAIL: 1.50)
    Test: Parameters = GOOD -
    Test: PM = GOOD -
    Test: Pitch/Roll = GOOD -
    Test: Thrust = GOOD -
    Test: VCC = GOOD -

This reply was deleted.