APM2 GPS Red LED and data help (CRASH REPORT, ANYONE ELSE?)

HI everyone,

I have been struggling with the APM2 that I have just installed and have been trying to fly in Auto and RTL modes. I do have the plane flying great in the stabilize mode and the fly by wire mode also works.

When I switch the plane to RTL or Auto mode the plane does fly itself (circle) and hold altitude but it does not go to the waypoint locations and it does not circle over the home or launch point. Every time I have flown I have waited for the blue led to go solid and also the 3Dfix led is solid. I have also connected to the computer outside and in the mission planner it says 3Dfix. I do NOT ever get a red led to stay on. The red led does flash when the board is first powered up but then has never stayed on solid like is says it is supposed to. See the link.

http://code.google.com/p/ardupilot-mega/wiki/LED

That brings be to my next problem. It was suggested to me to look at the data log and see if there is an actual gps lock. When trying to look at the data log in the mission planner I do not see any horizon changes, speed or altitude changes. It does say the log is playing but I am unable to see any of the planes functions.

I have been struggling with this for a week now and do not know what to try next. If anyone could give me some suggestions that would be greatly appreciated.

Thanks

Ryan

Tags: 3Dfix, AMP2, GPS, Red, data, led, log

Views: 1741

Reply to This

Replies to This Discussion

Have you tried pushing the reset button on top of the imu-board when the gps is locked and the red is flashing?

Yes I have. I have tried it while the lights are flashing, and after they are done flashing.

Either the wiki is wrong, or we both have defective boards... i've never seen the red led going solid, and since there is a dedicated blue led for GPS 3D fix...

Sorry, you're right. I forgot you guys were talking about ArduPlane, not ArduCopter. The red LED comes on with ArduCopter, not Plane with APM 2. Not sure why we didn't turn it on with Plane. I'll post an Issue to do that. 

One thought I just had while reading another post. Would the hatch magnets have any affect on the APM2?

OK I just found a data log that had a few bits of flight recorded. It says GPS: no fix.  Before I take off it says GPS 3Dfix. but in the air there is no fix? My APM2 is mounted in the front of the plane with only the clear canopy over the GPS.

On the ground it does show my location in the mission planner so there is a GPS fix. Why would it loose the fix once in the air?

Is this a defective board? 

Do you use telemetry ? Or you're just able to connect to mission planner using USB cable when the plane is on the ground ?

If you mean the remote telemetry. See link. I do not.

http://code.google.com/p/ardupilot-mega/wiki/APM2Wireless

I just plug into the board when it is on the ground. I downloaded all the logs and have them now I my computer. Possibly I am not looking at the telemetry logs correctly. Most of them that I have do not show anything going on at all. They do show lost packets and errors scripts. See attached jpg and I also attached a data log.

Please let me what I should be doing differently

Thanks

Attachments:

Have you tried to erase everything and reupload firmware ?

Good thought!!! Yes. There was an update to the mission planner Friday when I opened it so I downloaded that and uploaded the new version to the APM. No issues with the upload.

 

I am very confused as to why the data logs say "missing packet" "packet read error" and other error type messages. This is consistant with all my data logs.

I keep feeling like there should be a simple fix to this but I do not know where to look.

 

Thanks

Ryan

Has any one been able to take a look at this data log and see if they can see any issues? It does not seem to be working correctly for me but I have no experience with these data logs before this.

Thanks

Ryan

can someone pl tell what color light means what, i have the apm2 and i find there r 4 lights, if it can be elalorated that this colour is .........,    solid means ....,      flashing means this......, i will be really greatful, i could not find in anywhere .

RSS

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service