ArduPlane Level Calibrate Accel Greyed out. Can't see Manual Level option

Hi there, 

I'm new to ArduPilot and a in the process of setting up APM 2.5 on my plane with the latest versions (Arduplane 2.74b and Misson Planner 1.2.62).

I have been following the instructions at http://plane.ardupilot.com/wiki/flying/starting-up-and-calibrating-...

But when I go into Hardware > Mandatory Hardware > Arduplane Level, the "Calibrate Accel" is greyed out.

I would also like to manually calibrate level as my plane does not sit level on the ground (no wheels and round fuselage) but cannot see the Manual level tickbox or couldn't find it in any of the parameters.

I have tried searching for similar issues and did notice issue #113 (i think) relates to this, is there some workaround meantime? perhaps using the terminal/CLI?

Thanks (and apologies if I have missed anything obvious)

Tom

Tags: Accel, ArduPlane, Calibrate, Level, Manual

Views: 1747

Reply to This

Replies to This Discussion

Hi guys,

 

same problem for me too.

I tried searching on the forum but the search button does not work...

 

TNX!!

 

Hi, I am also having this problem.  I have a new, unflown APM2.5 and just loaded 2.74b firmware.  The box is sitting level on my bench but starts up reporting node up of 0.2 units and left roll of 2.2 units.  I've tried a reset to clear any old data but this has no effect.

Same as you, the hardware level function in Mission Planner is disabled.

Does anyone out there have any input?

Thanks! that worked perfectly.

To answer the other part of my original question, level calibration is always done manually in the latest APM:Plane firmware according to: https://github.com/diydrones/MissionPlanner/issues/113

This is a pretty big change to how APM has worked historically.  I believe the change was made to prevent problems with an airborne restart, but this is now a "required" step in all setups. 

I saw the problem two days ago with a new APM.  We couldn't see any reason why it was acting abnormally and not establishing level on startup.  FWIW, I build and use a bench support "frame" for every airplane.  This sets the planes at "level" when the power is connected, so the APM is leveled out on each startup.

Does anyone here know who is tasked with updating the online documentation?

Hi,

Yes, where "manually" means you don't have to do anything. Like what we often call "automatically" or "eliminated". I never understood why it was called "manual".

Regards

Soren

what a great idea, I need to take apart the plane to be able to connect via usb and issue the level command. very inconvenient

So can you use the terminal wirelessly? All I get is gibberish. I can't connect the USB while APM is in my plane and I dont see a lot of point calibrating it outside of the airframe. Confused? 

The gibberish is MAVLink.

APM will only accept going to terminal right after reset / power up. When going via USB there is a automatic reset of APM when connecting and when entering terminal, so it can be done anytime. This does not work via telemetry.

Try to connect, and then reset the APM eg. by cycling the power. You then have to enter terminal in MP immediately after powering APM back up.

As it is not, entering the terminal terminates all flight control and all MAVLink, that's why APM will let you only do that right after powerup (safety). Some time in the future (next MAVLink protocol version) the terminal will co-exist with flight control and MAVLink.

PS if MP makes trouble with its insisting on reading all parameters upon connect, you can use CTRL-T instead of the connect button. Or, for the APM terminal, use a plain old terminal emulator program and press ENTER 3 times after APM reset.

Regards

Soren

Many thanks! Im now able to access the terminal over the air, which is briliant, suddenly it all makes a lot more sense. 

Ctrl + T is also a handy shortcut

Cheers

What has happened is that the option to "have to set the level (i.e.keep the plane still and level) on each start-up" has been removed.

The button requiring the once-off manual levelling is still required and currently is (erroneously) greyed out in MP v1.2.62 and thus can only be done in the CLI.

Thanks for explaining, I like this, no more fiddling with a bubble level, in the wind, to get the plane level before each flight.

Changes/improvements are coming so thick and fast, I fully understand Michael Oborne not catching all the changes !

Removing the Mission Planner's manual leveling ability was not an oversight, it appears to have been directed by "Tridge" from the developers group.  Here's his email to Michael Osborne telling him to disable that ability in MP --

Hi Michael,
The stable version of APM:Plane has now removed the MANUAL_LEVEL option - it now behaves the same as copter and rover, where you always need to do a manual level, you can't choose to auto-level on each startup.
Can you remove the MANUAL_LEVEL option in MP?
There are also quite a few other parameter changes, such as the new TECS parameters, and new attitude controller parameters, plus quite a few removed.
Cheers, Tridge


Reply to this email directly or view it on GitHub.

They just didn't test this enough to see that it now needs a terminal emulator over telemetry for the many cases where the APM hardware is enclosed inside the airplane and cannot be reached through the USB port.  Let's hope he redirects Michael to solve this problem in MP's terminal acreen.

RSS

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service