Hi everyone,

I'm building a heavy Octo for aerial photo & video based on the APM2 board + Carbon Core Octocopter1000 with 360 Pano Mount and Mega Radius camera mount.

The power is provided by two Turnigy nano-tech 6000Mah 6C batteries connected to 8 Himodel 40Amp ESCs powering 8 Tiger motor MT3515-15 400Kv motors with Master Airscrew 14x7 3-blade propellers fitted.

The theorical maximum amp draw for each motor is 29Amps making a theorical max Amp draw of 232Amps. I want to measure battery Voltage and current draw but the biggest AttoPilot Current & voltage sensor is rated for 180Amps Max.

I know I'ts impossible or near impossible to go to max Amps with all motors at same time doing AP but given that burning the Attopilot sensor will stop the power feed to the multicopter, and this will result in a more than sure crash, I want to be very conservative and not overload it.

Is there an option to connect two 180Amp sensors to the APM2 board (one on each battery) and get readings?

Two sensors should be capable of handling 360Amps and this would solve my problem.

Other sugestions?

Views: 4427

Reply to This

Replies to This Discussion

I know this thread is a bit old but is there any further info on this? I am also looking for a sensor that will work beyond 180A.

Ecalc tells me my max current will be 217 so not too far over and I probably wont go that high but I don't want to risk it...

Same problem for me guys.. I need to use 12S battery connection and 220A current draw at max. Is there no simple alternative to AttoPilot180A ?

In the end I've bypassed the attopilot completely and have the current /voltage sensing done via the frsky. Less to worry about and I never liked the way the atto looks so easy to short!

Attopilot is difficult to found in Europe, why not use the wire as shunt like this :

wire as shunt

There are power modules available on eBay that handle up to 8S batteries. I think 3DR might even have them now. People report some quality control issues from time to time but I'm using one rated for 8S with my dual 6S batteries on a hexa and it's working fine. I only monitor one battery as that gives me the correct voltage and I just double the current reading displayed for an approx current draw. But you could probably set the current calculation to do that for you if you want a proper display. Monitoring one battery isn't perfect but it's worked find for me for years now. BTW, if you order a power module off eBay get a longer cable for the connection to the APM/Pixhawk as well. They are cheap and come in very handy. Here's one example of a PM from eBay:

http://www.ebay.com.au/itm/APM2-6-Flight-Control-Board-Pixhawk-Powe...

Warning, using attopilot with draw more than 180 can be dangerous because the power consumation grow wtih square of current :

P = I² * R

actual attopilot for 180A :

180*180*0.00025 = 8.1 watts

if you draw 272A

272*272*0.00025 = 18.4 watts

In my case with parallel batterys, I used the Attopilot on only one battery feed.  The voltage is correct, and I adjust the pixhawk parameter to adjust "amps per volt," to compensate for the additional current.  With a little fiddling it seems to work.

On a similar, related subject, your max current is 200+ amps, so you expect to draw 1/2 that current from each battery?  My situation is similar.  However once in flight I am finding serious voltage lag triggering battery fail safe way to soon.  This indicates I am pulling more current than the battery is capable of delivering.

I sent a message to the guys at AtomikRC and they responded that the parallel battery arrangement will deliver the current on ONE battery pack, and that with lipo battery you do not get to multiply the current C rating by the number of battery packs.

I'm doubtful of this response but I suppose that internal balancing of the cells between packs may be using current capacity.  I'm considering a balance cable between the lipo packs.

Any thoughts?

What is the correct way to connect the AttoPilot 180A ground wire without causing a ground loop when using two separately fed 6Ss into a PDB while only sensing one of the packs (I only want to monitor 1 pack)? Pixhawk is powered via the top power port using the original Pixhawk PM via a separate 3S (I’m not running the Pixhawk from the PDB).

 

I have hit a massive dead end after trawling the forums for hours, help greatly appreciated.

 

Thanks

my X8 can pull up to 531 amps so can I even use a current sensor?

How would I then wire that to my osd ? I have a vector eagle tree osd
I was thinking of getting a pixhawks cube but I'm wondering if I can make this dull current sensor thing work with my eagle tree vector too?????

Reply to Discussion

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service