I received a new prebuilt Arducopter last week from Udrones and I am having some problems getting ti to fly with the stability that I am expecting.

I am partially there, but I need some help.  I have been pouring over all the information I can find, but some nagging issues seem eluding me, I can't seem to find the answers.

The Arducopter arrived with the standard blue motors, 20 Map ESC's The 2.5 MP, a Sonar sensor, The 3DR Radio kit and everything wired, and set up from Udrones.  I installed my radio receiver (Spectrum AR8000), installed, installed the Mission Planner, did the update, got it working on the USB port and got it working with the Radio (FT232 driver).

Here's the problem I have. In Flying mode "stabilize", initially I have a lot of drift, It flew exactly like a Heli that just has conventional gyro stabilization, which now I understand is what it is supposed to do, but It had a lot of bias, and even with no wind, would move pretty aggressively rather than stay in one spot. So I set up my other flight modes, position and loiter.

Positon hold seemed to be better but it still tried to wander and needed constant control of throttle to keep it at a particular altitude. Ok, so I guess that is somewhat normal except that I would expect it to hold its location better than it does. So then I tried the Loiter mode. In Loiter mode, it immediately begins climbing, and only if I drop the throttle to 0 does the climb stop. 

In testing that mode, I have learned to put the throttle back up to mid stick and then switch back to stabilize quickly.  

Then I found that in stabilized mode, by adjusting the trims for pitch and roll, I could get the Arducopter to remain fairly stable although I have to be very active on the throttle stick to maintain altitude. 

I ran the level routine with my ArduCopter completely level, with the trims back to neutral and tried a test flight again, and I still had to adjust my trims to get it to hover in in spot. 

I think I can deal with that, and will have to learn about adjusting the PIDS to get the stability I want.

1. Which brings me to this question: can I save my entire configuration before I start attempting to find tune the PIDS, so I can revert back to factory by reloading the configuration without having to re-install?

I started to try and figure out why it wants to climb when I switch to Loiter mode;  I wonder if the Sonar/GPS/BARO  combination is somehow needing to be tweaked, or if there is a faulty hardware, or setting. In the Mission Planner, under Advanced Params..

2. I notice that AHRS_BARO_USE is disabled "0"   Is that right?

3. the next parameter: AHRS_GPS_GAIN is set to 0, is that right?

Should those be enabled and set?

It seems to me that these settings might be relevant, but I am new to all this.

As a test, I have disable the Sonar, and I want to try a test flight to see how this affects the altitude stabilization, but unfortunately the winds right now are gusting beyond 20 MPH, so not a good time to test fly.

Here is the config that I have right now, does this look right for default PIDS for a new aducopter 2.5? the loiter Rate P seems higher than Pitch/Roll P values, but what do I know, none of these are messed with, are they correct starting points?

If someone could help me understand this, thanks in advance!

Richard

Views: 1321

Reply to This

Replies to This Discussion

For saving configuration you can go to advanced parameter list screen, then there is an option to save.  That way you can restore at any time.  Note it will restore everything including dynamic compass calibration values, radio limits etc..

For the 'baro use' option I also have mine set to zero but I still get baro.  Probably just an exotic option safe to ignore.  I also have gps gain set to zero without issue.

For the altitude control issue, try changing your throttle rate to values between 0.1500 and 0.6000 .  You can do this using the channel 6 option which is highlighted in your picture.  Just select the value you want to change from the list (the names are a bit cryptic) and be very sure to set the minimum and maximum values correctly.

Then, assign a dial on your transmitter to a spare channel (say channel 8).  Then connect channel 8 on your receiver to the 6th channel on the APM.  You can then adjust the parameter during flight by moving your dial.  I would suggest starting by tuning throttle rate p and rate roll p.  They are the most noticable.

Another note, be careful to refresh values from the flight controller when you are modifying the channel 6 options in mission planner.  I believe there is a bug (it might be fixed) where some of the fields get blanked out if you hit save in the wrong order.  To be safe I recommend refreshing the screen after all changes.  It has the extra benefit of showing you the exact value your channel 6 dial is pointing to.

Thanks a lot for the tips, I did find a parameter file for the Arducopter on the downloads, and figure out how to load it and then update the settings on the arducopter using the mission planner. I haven't had a chance to try it other than lifting off in my living room just for a basic stability test. There were quite a few settings that were markedly different, so I will be interested on how it performs when I can test Loiter mode again. Thanks for your help and warnings about the refresh. 

I will also learn to use the channel 6 tuning method. 

Thanks again

Richard

Finally got to work on getting my week old Arducopter dialed in. I have a stock new Arducopter with the blue motors (AC2830-385m 850kv) with the stock esc.s the APM 2.5, with 2.8.1 uploaded and the 3DR Arducopter param file with no changes, except for toggling AHRS_BARO_USE to enable (I don't know, but I guess this should be enabled if you want to add the barometer sensor data to the auto altitude hold calculation.

Still, i have the problem I have had since the beginning. as soon as I turn on loiter, it climbs aggressively. I have to react going back to stablilize right away to stop its climb (If I were at the flying field I could let it go a bit).

But I'm puzzled, what do I do to trouble shoot this. Altitude hold seems to be working fairly well, (until I enable the Baro, it wasn't maintaining altitude I believe, (I've tried so many things I'm not sure)

anybody got any ideas?

Are you using APM 2.5 in the enclosure with the foam? If not, you need to cover the baro sensor with some foam or cotton. 

It has an cover/enclosure, it is as shipped from Udrones when you buy a prebuilt Arducopter..  if that is what you mean??

Yes, that's the enclosure. So that should be fine. If alt hold is working, Loiter should be working as well. Are you sure that's the mode you're going into, and not something like RTL (which uses a pre-set altitude that you can set in the MP)?

Well in MP, when I operate the switch on the transmitter, in POS1 mission planner shows stabilize. 

Postion 2 on the transmitter shows it going to mode 4, and I have it set to altitude hold, then position 3 on the transmitter  takes it to mode 6 which is set to loiter. all the other modes are set to stabilize. I can only toggle the switch and confirm that the highlighted mode is what I expect. It would appear to be correct looking at the mission planner mode settings page.

I just noticed a mistake,, In channel 6 I don't have loiter set, I have OF_Loiter set.. 

Strange, but I didn't notice that before, nor do I know what it is.

Ah.., I see that "of_loiter"  is for the optical flow sensor which I don't have. I will set it correctly and see if that solves the problem. we will see tomorrow, too dark to try again now here in Texas

Thanks

Richard

Got some more improvement today, evidently I wasn't getting good altitude stabilization because my mode setting for loiter was set to of_loiter by mistake. It was climbing when I switched to the mode. now that is working properly. I still am getting a lot of wandering when in loiter mode. it seems to hold pretty well for a short while and then will just start moving in an arbitrary direction and keep on until I override it  and pull it back. I did a precision level, did "auto trim" in the air and tried increasing GPS gain, and several other things. It seemed like altitude hold was maintaining position better that loiter!.

I am suspecting vibration, the supplied setup with the motors, and compression fit collets are the reason. with the props off, it will walk across the table when I run the throttle up. visually you can see the run-out of the collets when spinning. 

I have some DJI motors and collets coming in and should eliminate any vibration.

I won't get them until after New Years now, but I will look in the meantime to see if I can do something to make these props run true.

Richard

Which GPS are you using? The uBlox should give the best loiter performance. 

Hi Chris.. It is the UBLox, part of the standard Udrones package I recieved a few weeks ago. I locks on even indoors, I am happy about that. outdoors, it 3d locks in less than a minute, then on the mission planner it doesn't move. I think the GPS is good, I'm not so sure its data is being applied in loiter mode though, I don't understand the parameters well enough to check that, but something could be set wrong. I almost think GPS is not being used at all when inn loiter mode, as I was saying, it seemed more prone to hover in one spot when just in altitude hold mode.   AHRS GPS Gain was at default (0 gain)  in the param file I found dated in December on the downloads site, that is what I'm using. I tried adding some gain, but seemed to have zero effect. Not sure what to look at next. Could it be vibration?

Loiter is much improved in 2.9, which will be out in a week or two. I'd wait for that before you start tuning. 

RSS

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service